Viewing 1 reply thread
  • Author
    • #13376
      Stefano Grespan


        I’m trying to migrate my Otobo (docker installation) to another machine. I’ve followed the guide and everything went fine until the restore. Error message:

        docker run -it --rm --volume otobo_opt_otobo:/opt/otobo --volume otobo_backup:/otobo_backup --network otobo_default rotheross/otobo:latest-10_1 scripts/ -d /opt/otobo -b /otobo_backup/2022-06-23_17-06-15
        Restore /otobo_backup/2022-06-23_17-06-15/Config.tar.gz ...
        DBI connect('database=otobo;host=db','otobo',...) failed: Access denied for user 'otobo'@'' (using password: YES) at /opt/otobo_install/local/lib/perl5/DBIx/ line 31.
        ERROR: Perl: 5.34.1 OS: linux Time: Fri Jun 24 11:39:39 2022

        Message: Access denied for user 'otobo'@'' (using password: YES)

        Traceback (1):
        Module: Kernel::System::DB::Prepare Line: 767
        Module: /opt/otobo/scripts/ Line: 179

        Can't call method "fetchrow_array" on an undefined value at /opt/otobo/Kernel/System/ line 847.

        I’ve tried to login in the db with user Otobo and it works:

        /$ docker exec -it otobo_db_1 /bin/bash
        mysql@293fdd6b2c98:/$ mysql -u otobo -p
        Enter password:
        Welcome to the MariaDB monitor. Commands end with ; or \g.
        Your MariaDB connection id is 17867
        Server version: 10.5.16-MariaDB-1:10.5.16+maria~focal binary distribution

        Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

        Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

        MariaDB [(none)]>


      • #13378
        Stefano Grespan

          Solved: to import the backup I had to change otobo user password on the new server and give it the same it had on the old one.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.