Topic Resolution: Answered
Viewing 8 reply threads
  • Author
    Posts
    • #14028
      Answered
      Dragan Dobric
      Participant

        Hi everyone,

        We are trying to create mail account using OAuth with IMAP as described in Docs » Communication & Notifications » PostMaster Mail Accounts.

        Everything goes fine until saving the new created account.

        There, when we click on the save button, we are supposed to login on the office365 account (which we did) and redirected to OTOBO customer’s login page.

        So when we go back to admin panel » Mail Account Management newly created account doesn’t exists. It is not possible to fetch mail.

         

        Our version of OTOBO is 10.1.5 – Docker based installation.

        Also we first tried with the older version 10.0.11 who was migrated from OTRS, and then with 10.0.16 but with same results.

         

        Any help would be apricate?

        Thank you

        Dragan

      • #14045
        marcel-graf
        Participant

          Hello Dragon,

          use you the otobo server with http or https? With http, you must change the Redirected URL from https to http.

          KR,

          Marcel

           

           

        • #14059
          B O
          Participant

            Hi Dragan,

             

            did the above mentioned solution from Marcel solved your problem, cause I’m facing exactly the same issue.

            Thank you,

             

          • #14152
            Dragan Dobric
            Participant

              Hello,

              In fact, the Otobo server already uses https.
              However, my certificate has expired, which should be the reason of this problem.
              Marcel’s advice definitely directed me in this direction, and (hopefully) after I’ve solved it, I’ll report back here.

               

               

            • #14184
              Michael Eißler
              Participant

                Hi Dragon,

                did you find a solution for your issue? I´m facing the same.

                No Mailaccount after the redirection to OTOBO login.

                Thanks!

                 

                 

              • #14192
                Dragan Dobric
                Participant

                  No, still no solution for this…

                  So problem is that https://<My OTOBO address>/otobo/index.pl?Action=AdminMailAccount not respodning…

                  We tried everythin from the documentation

                  https://doc.otobo.org/manual/admin/10.1/en/content/communication-notifications/postmaster-mail-accounts.html#pop3-and-imap-oauth2-authentification

                  also, everything in Azure look good.

                  Are there any tips? Could I test this endpoint somehow?

                   

                   

                • #14194
                  Best Answer
                  Stefan Rother
                  Keymaster

                    Hi,

                    you need to change in your OTOBO FQDN. What is your OTOBO FQDN and what did you add to azure as redirect url?

                    When an error like this occurs, something is wrong with the configuration.
                    Either something is not set up correctly in Azure, or something is wrong in OTOBO.

                    I’m not really familiar with Azure either, but I’ve already been able to help about 10-15 of our support customers by going through everything again and check all values.

                    Best wishes,

                    Stefan

                  • #14195
                    Michael Eißler
                    Participant

                      Hello,

                      I found the solution for me. I enabled  “SessionUseCookie” in System Configuration –> Core –> Session –> SessionUseCookie

                      My assumption is, the login in Otobo after the redirection from Azure is interfering the authentication process.

                      Note: I also enabled SessionUseCookieAfterBrowserClose, but I think the above mentioned setting was the important one.

                      Hope this helps you also!

                      BR

                      Michael

                    • #14224
                      Dragan Dobric
                      Participant

                        Problem solved,

                        Stefan’s proposal was correct 👍. There was wrong letter in the redirect url.

                        As I myself have no access to the company’s Azure tenant, I created redirect url manually and compared with the one that’s generated from the Azure, so that’s how I founded it actually…

                        Also, after I fixed it I played around with the Michael’s tips regarding setting “SessionUseCookieAfterBrowserClose” but it seems like there is no impact on this.

                        Thank you

                         

                    Viewing 8 reply threads
                    • You must be logged in to reply to this topic.