Viewing 4 reply threads
  • Author
    Posts
    • #14877
      Tino Süß
      Participant

        Hallo liebe Community,

        vielleicht kann mir jemand weiter helfen.

        Ich habe eine Otobo-Installation mit Apache und einer MySQL-Datenbank auf einem Ubuntu 20.4 System.
        Die Authentifizierung erfolgt über LDAP, was auch weitgehend funktioniert, leider bekomme ich auf der Anmeldeseite des Kundenbenutzers die Fehlermeldung

        Authentifizierung erfolgreich, aber im Kunden Backend wurde kein Kunden Eintrag gefunden. Bitte kontaktieren sie ihren Administrator.

        Einen Kunden habe ich angelegt.
        Was fehlt mir noch, was mache ich falsch?

        Vielen Dank
        Gruß
        Tino

         

         

      • #14878
        marcel-graf
        Participant

          Hallo Tino,

          ich nehme an, du hast in der Systemverwaltung einne Kunden + den Kundenbenutzer angelegt?

          Es gibt ja den Abschnitt LDAP AUTH  und dann noch den Abschnitt, wo die User per LDAP gelistet werden.

          Eventuell mal deinen LDAP Config ohne Live Daten posten.

          Hier mal ein Teil unseres Customer Abschnitts:

          ###########################################
          # Customer User LDAP Backend and Settings #
          ###########################################

          $Self->{CustomerUser1} = {
          Module => ‘Kernel::System::CustomerUser::LDAP’,
          Params => {
          Host => ‘ldap://server’,
          BaseDN => ‘DC=xxx,DC=int’,
          SSCOPE => ‘sub’,
          UserDN => ‘cn=otrs user, ou=User_Special, dc=domain, dc=local’,
          UserPw => ‘xxxxxxxx’,
          AlwaysFilter => ‘(&(objectCategory=person)(objectClass=user)(!(userAccountControl:1.2.840.113556.1.4.803:=2))(mail=*)(sn=*)(givenname=*)(!(givenname=\00)))’
          SourceCharset => ‘utf-8’,
          DestCharset => ‘utf-8’,
          Params => {
          # sslversion => ‘tlsv1_2’,
          #},
          port => 389,
          timeout => 120,
          async => 0,
          version => 3,
          },
          },
          CustomerKey => ‘sAMAccountName’,
          CustomerID => ‘mail’,
          CustomerUserListFields => [‘cn’, ‘mail’],
          CustomerUserSearchFields => [‘sAMAccountName’, ‘cn’, ‘mail’, ‘sn’, ‘mobile’, ‘telephonenumber’],
          CustomerUserPostMasterSearchFields => [‘mail’],
          CustomerUserNameFields => [‘givenname’, ‘sn’],
          # CacheTTL => 1200,
          Map => [
          [ ‘UserSalutation’, ‘Title’, ‘title’, 1, 0, ‘var’ ],
          [ ‘UserFirstname’, ‘Firstname’, ‘givenname’, 1, 1, ‘var’ ],
          [ ‘UserLastname’, ‘Lastname’, ‘sn’, 1, 1, ‘var’ ],
          [ ‘UserLogin’, ‘Login’, ‘sAMAccountName’, 1, 1, ‘var’ ],
          [ ‘UserEmail’, ‘Email’, ‘mail’, 1, 1, ‘var’ ],
          [ ‘UserCustomerID’, ‘CustomerID’, ‘mail’, 0, 1, ‘var’ ],
          [ ‘UserPhone’, ‘Phone’, ‘telephonenumber’, 1, 0, ‘var’ ],
          [ ‘UserMobile’, ‘Mobile’, ‘mobile’, 1, 0, ‘var’ ],
          [ ‘UserAddress’, ‘Address’, ‘postaladdress’, 1, 0, ‘var’ ],
          ],
          };

          #################################################################################################

           

          Gruß Marcel

           

           

           

           

        • #14884
          Tino Süß
          Participant

            Hallo Marcel,

            vielen Dank für deine Antwort.
            Meine LADAP-Config sieht so ähnlich aus

            # (customer user ldap backend and settings)
            $Self->{CustomerUser} = {
            Name => ‘LDAP Backend’,
            Module => ‘Kernel::System::CustomerUser::LDAP’,
            Params => {
            # ldap host
            Host => ‘xxxx.xxx.de’,
            BaseDN => ‘ou=xxxx,ou=xxxx,dc=xxx,dc=de’,
            # search scope (one|sub)
            SSCOPE => ‘sub’,
            UserDN => ‘cn=user,ou=Service,ou=dc=xxx,dc=de’,
            UserPw => ‘xxxxx’,
            AlwaysFilter => ”,
            Die => 0,
            Params => {
            port => 389,
            timeout => 120,
            async => 0,
            version => 3,
            },
            },
            CustomerKey => ‘uid’,
            CustomerID => ‘mail’,
            CustomerUserListFields => [‘cn’, ‘mail’],
            CustomerUserSearchPrefix => ”,
            CustomerUserSearchSuffix => ‘*’,
            CustomerUserSearchListLimit => 250,
            CustomerUserPostMasterSearchFields => [‘mail’],
            CustomerUserNameFields => [‘givenname’, ‘sn’],
            CustomerUserNameFieldsJoin => ”,
            CustomerUserExcludePrimaryCustomerID => 0,
            AdminSetPreferences => 0,
            CacheTTL => 0,
            Map => [
            [ ‘UserTitle’, Translatable(‘Title or salutation’), ‘title’, 1, 0, ‘var’, ”, 1, undef, undef ],
            [ ‘UserFirstname’, Translatable(‘Firstname’), ‘givenname’, 1, 1, ‘var’, ”, 1, undef, undef ],
            [ ‘UserLastname’, Translatable(‘Lastname’), ‘sn’, 1, 1, ‘var’, ”, 1, undef, undef ],
            [ ‘UserLogin’, Translatable(‘Username’), ‘uid’, 1, 1, ‘var’, ”, 1, undef, undef ],
            [ ‘UserEmail’, Translatable(‘Email’), ‘mail’, 1, 1, ‘var’, ”, 1, undef, undef ],
            [ ‘UserCustomerID’, Translatable(‘CustomerID’), ‘mail’, 0, 1, ‘var’, ”, 1, undef, undef ],
            [ ‘UserPhone’, Translatable(‘Phone’), ‘telephonenumber’, 1, 0, ‘var’, ”, 1, undef, undef ],
            [ ‘UserAddress’, Translatable(‘Address’), ‘postaladdress’, 1, 0, ‘var’, ”, 1, undef, undef ],
            [ ‘UserComment’, Translatable(‘Comment’), ‘description’, 1, 0, ‘var’, ”, 1, undef, undef ],
            ],
            };
            #############################
            Gruß
            Tino

             

             

          • #14957
            Stefan Abel
            Moderator

              Hallo,

              du hast glaub ich schon erkannt, es gibt zwei Module: eines für die Authentifizierung, eines für die Synchronisation. Das klingt, als klappt das erste, aber noch nicht die zweite.

              Aus der Ferne jetzt Hilfe zu geben ist schwierig. Das Systemprotokoll (oder das Log an sich) gibt dir aber einen Hinweis, was schief läuft.

              ldap:// kannst du bspw. weglassen. das ist nur interessant, wenn du LDAPS nutzen willst (dann brauchst du ldaps:// und den Port 636).
              AlwaysFilter würde ich auskommentieren, wenn du keinen Filter benutzen willst.

              [ ‚UserLogin‘, Translatable(‚Username‘), ‚uid‘, 1, 1, ‚var‘, “, 1, undef, undef ], und
              CustomerKey => ‚uid‘,
              … funktioniert nur, wenn du auch eine uid hast. Microsoft ActiveDirectory bspw. hat stattdessen den sAMAccountName.

              Ansonsten ist auch wichtig, dass die Pflichtfelder (zum einen Mailadresse + Login, zum anderen alles was dein Mapping mit einer “1” als Pflichtfeld definiert) auch einen Wert haben.

              Ich hoffe, das hilft weiter. Ansonsten müsstest du bitte mal einen Auszug aus dem Systemprotokoll schicken (ggf. vorher Loglevel auf Debug stellen in der Systemkonfiguration).

              Viele Grüße
              Stefan

            • #14995
              Tino Süß
              Participant

                Vielen Dank für eure Unterstützung, jetzt hat alles funktioniert. :)

                Gruß
                Tino

            Viewing 4 reply threads
            • You must be logged in to reply to this topic.