Viewing 5 reply threads
  • Author
    Posts
    • #13681
      Goran Plavsic
      Participant

      Hallo zusammen

      Wir sind gerade dabei Otobo zu testen und möchten es wenn möglich in Azure als App Service betreiben. Leider konnten wir das Deployment bisher in Azure nicht erfolgreich realisieren.

      Gibt es evtl. schon Deployments in Azure und was gibt es dabei zu beachten?

    • #13683
      Goran Plavsic
      Participant

      Das Problem konnte behoben werden und Otobo konnte erfolgreich nach Azure App Service migriert werden. Die Problematik war dass die ENV Variablen leider in Docker Compose nicht unterstützt werden (Docker Compose ist zurzeit in Azure auch nur im Preview verfügbar, evtl. kommt wird dies aber bald unterstützt).

    • #13685
      bes
      Participant

      Hallo Goran,

      sehr gut dass es mit Azure App Service dann geklappt hat. Soweit ich weiss habe wir das bei RotherOSS bisher noch nicht getestet. Wenn du eine Anleitung oder Findings hast, dann würde wir das gerne in die Doku integrieren.

      Die Verwendung von Docker Compose hat übrigens keine tieferen technischen Gründe. Es war im Prinzip nur die einfachste Möglichkeit die Docker Images zu deployen. Die Images können als auch in anderen Umgebungen verwendet werden.

      Viele Grüße,

      Bernhard

       

       

    • #13690
      Goran Plavsic
      Participant

      Hallo Bes, ich werde dies gerne sharen sobald alles funktioniert. Momentan bin ich seit Stunden damit beschäftigt eine dedizierte Datenbank (MariaDB in Azure) anzubinden. Leider schlägt der Installer immer wieder fehl, evtl. hast du da noch eine Idee an was dies liegen könnte?

      Ich habe die Datenbank und auch den Benutzer manuell angelegt, da der Installer bereits schon beim erstellen des Users fehlschlägt. Bei MariaDB in Azure kann ich leider „mysql_native_password‘“ nicht setzen. Nachdem ich die Erstellung des Benutzers und der DB gemacht habe, komme ich mit dem Otobo Installer weiter, er legt die Tabellen an, etc. aber leider bricht der Installer nach genau 4 Minuten mit einem 504 Error ab:

      Es sieht mir fast so wie ein Timeout aus, auf der MariaDB habe ich bereits die Timeouts hochgesetzt aber leider ohne Erfolg. Vielleicht hat jemand noch eine Idee? Der Abbruch erfolgt nach genau 4 Minuten (mehrmals getestet).

      Ich würde ungerne die MariaDB in der produktiven Instanz auf dem Container betreiben. Für Development ist es in Ordnung aber für die produktive Nutzung würde ich die DB gerne dediziert betreiben.

    • #13691
      bes
      Participant

      Hallo Goran,

      eine Ferndiagnose ist da natürlich schwierig. Du schreibst das bereits der User nicht angelegt werden kann. Das ist nachvollziehbar wenn die Azure MySQL DB speziell konfiguriert ist. Im Code, https://github.com/RotherOSS/otobo/blob/rel-10_1/Kernel/Modules/Installer.pm#L507, ist nur der einfachste Fall unterstützt.

      Beim Timeout ist komisch dass erst abgebrochen wird nachdem die Tabellen erstellt worden sind. Ist auch die letzte Table „data_storage“ erstellt worden? Bzw ist die Tabelle „valid“, die als erste befüllt wird, komplett leer?

      Im Nofall kann man immer installer.pl mit der Docker Compose Datenbank durchlaufen lassen. Dann kann man die DB exportieren und in die Azure-DB importieren. Kernel/Config.pm muss man dann manuell anpassen.

      Ich hoffe das hilft ein bisschen,

      Bernhard

       

       

       

       

    • #13775
      Goran Plavsic
      Participant

      Hallo zusammen

      ein kleines Update zu dem Deployment in Azure App Services mit Docker Compose. Ich habe es nun hinbekommen das Deployment zu machen, auch die DB konnte erfolgreich erstellt werden. Das Problem welches in Azure App Services existiert ist, dass Elasticsearch leider nicht verwendet werden kann, wir erhalten die folgende Fehlermeldung:

      max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

      Nach langem versuchen ist es leider nicht möglich diesen Wert in Azure zu erhöhen, weshalb der Container leider immer wieder gestoppt wird.

      Weitere Informationen hierzu:

      https://social.msdn.microsoft.com/Forums/azure/en-US/d0235991-3b5f-473b-a422-93da07c80ea0/elasticsearch-container-increase-vmmaxmapcount?forum=AzureContainerServices

      Bei der Verwendung von einer älteren Version von Elasticsearch (elasticsearch:5.6.14-alpine), kann der Container erfolgreich gestartet werden. Nur ist die 5.6.14 bereits schon mehr als 4 Jahre alt und wir werden diese nicht verwenden, somit ist das Deployment auf Azure Web App mit Docker Compose zurzeit nicht möglich.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.