Viewing 1 reply thread
  • Author
    Posts
    • #13351
      Diego Ritunnano
      Participant

      Hallo,

      Ich verwende Otobo 10.0.15 ohne Docker.
      Ich habe ein Problem beim Versuch, ein E-Mail-Konto mit OAuth mit IMAP zu verbinden. Der Fehler zeigt die nächste Meldung: „Zugriffstoken konnte nicht angefordert werden“.
      Das Konto befindet sich in Azure AD und die Verbindung mit Office 365. Die Konfiguration ist mandantenspezifisch, daher habe ich die Mandanten-ID bereits anstelle von „common“ in den URLs von „/authorize“ und „/token“ festgelegt die Provider-Konfiguration.
      In Azure habe ich die Berechtigungen von „offline_access“, „IMAP.AccessAsUser.All“ und „User.Read“ vergeben und bereits eine Web-Authentifizierung mit der Umleitungs-URL „https://fqdn/otobo/index.pl? Action=AdminMailAccount“.

      Ich habe bereits versucht, Zugriffstoken (impliziter Fluss) und ID-Token (impliziter und hybrider Fluss) in der Azure-Anwendung zu aktivieren und zu deaktivieren. Ich habe versucht, den öffentlichen Fluss zu deaktivieren und zu aktivieren.

      In Otobo wird der Scope-Parameter in der Provider-Konfiguration eingestellt mit:
      https://graph.microsoft.com/offline_access https://graph.microsoft.com/POP.AccessAsUser.All https://graph.microsoft.com/User.Read“

      Zuerst habe ich es mit den Standardwerten versucht:
      „offline_access https://outlook.office.com/IMAP.AccessAsUser.All“
      Mit dieser Konfiguration konnte ich sehen, dass die Kontoanmeldung in Azure-Protokollen erfolgreich war, aber Otobo hat beim Versuch, das Postfach zu lesen, eine Zeitüberschreitung erreicht.

      Schließlich ist der Datenverkehr vom und zum Server nicht eingeschränkt, da dasselbe mit IMAP konfigurierte Konto einwandfrei funktioniert.

      Vielen Dank für Ihre Hilfe,

      Diego.

    • #13352
      Diego Ritunnano
      Participant
Viewing 1 reply thread
  • You must be logged in to reply to this topic.