Topic Resolution: Resolved
Viewing 4 reply threads
  • Author
    Posts
    • #15121
      Daniel Leidenheimer
      Participant

        Hallo,

        ich versuche nun seit 2 Tagen eine Otobo Instanz aufzubauen. Allerdings klappt es einfach nicht.

        Ich hatte es erst auf einem bestehenden Docker Host getestet. Dort hat es nicht korrekt funktioniert. Also hab ich heute nochmal eine neue Ubunutu 22.04 VM hochgezogen und mich Step für Step an die Installationsanleitung gehalten. Allerdings ebenfalls keine Erfolg.

        Der Ablauf:

        apt install git docker docker-compose curl
        2 cd /opt/
        3 ls
        4 git clone https://github.com/RotherOSS/otobo-docker.git --branch rel-10_1 --single-branch
        5 ls otobo-docker/
        6 ls
        7 cd otobo-docker/
        8 ls
        9 cat README.md
        10 cp -p .docker_compose_env_http .env
        11 vim .env
        12 nano .env
        13 docker-compose up -d

        Die Container werden korrekt gestartet. Es ist allerdings unmöglich die install.pl aufzurufen. Sobald ich das tue werde ich direkt auf die index.pl umgeleitet und bekomm ein Fehlermeldung das der User oboto sich nicht an dem datenbank server anmelden kann.

        Ich hatte erst gedacht es liegt am Browser. Also hab ich mal Chrome,Edge,Firefox,Opera und Safari getestet. Allerdings immer mit dem selben Ergebnis. Sobald ich /otobo/install.pl aufrufen werde ich direkt auf /otobo/index.pl umgeleitet.

         

      • #15125
        marcel-graf
        Participant

          Hallo Daniel,

          hier mal meine vorgehensweise.

          — Install Ubuntu Server VM — 20.04.5 oder neuer

          [X] aktualisieren auf neuen installer
          [X] install open SSH Server
          —————————————–
          sudo apt update
          sudo apt upgrade

          sudo apt install net-tools

          — Zeitzone Einstellen —

          timedatectl list-timezones
          sudo timedatectl set-timezone Europe/Berlin
          prüfen mit “date” bzw. “timedatectl”

          —- Install Docker —

          sudo apt-get install git docker docker-compose curl
          sudo systemctl enable docker

          sudo apt update
          sudo apt upgrade

          — otobo install —
          cd /opt

          sudo git clone https://github.com/RotherOSS/otobo-docker.git –branch rel-10_1 –single-branch

          ls otobo-docker # just a sanity check, README.md should exist

          cd /opt/otobo-docker

          sudo cp -p .docker_compose_env_http .env

          sudo nano .env (file edit -> OTOBO_DB_ROOT_PASSWORD=<your_secret_password>) STRG + X = close / Y = save

          sudo docker-compose up –detach

          sudo docker-compose ps
          sudo docker volume ls

          Run the OTOBO installer at http://yourIPorFQDN/otobo/installer.pl

          — Schritt 1 —
          durchklicken
          — Schritt2 —
          installer durchklicken -> MYsql ->neue DB

          generiertes Kennwort speichern: bgZ0uDDxxxxxxxxx

          Meldung Datenbank erfolgreich erstellt

          — Schritt 3 —
          http type = http or https
          FQDN und weitere felder füllen

          Email Konfigurtation überspringen -> kommt später

          ———————————————
          Startseite:
          http://yourIPorFQDN/otobo/index.pl
          Benutzer:
          root@localhost
          Passwort:
          OCu2xxxxxxxx

          Wenn im System eingeloggt unter Admin-> Systemkonfiguration nach SMTP Suchen und dort die entsprechenden Einstellungen vornehmen.

          Damit habe ich schon mehrfach das OTOBO installiert.

          Gruß Marcel

          • This reply was modified 11 months, 4 weeks ago by marcel-graf.
        • #15132
          Daniel Leidenheimer
          Participant

            Ich habs nun nochmal probiert. Ich habe noch mal eine komplett neue Ubuntu 22.04 LTS VM aufgesetzt. und nochmal komplett gepatched und dann otobo über docker-compose installiert. Ich habe mich auch noch mal stritt für schritt an deine anleitung gehalten.

            Die Installation auf Kommandozeile ist kein Problem.

            Ich kann aber die install.pl nicht aufrufen. Ich kann machen was ich will sobald ich versuche install.pl aufzurufen werde ich sofort auf index.pl umgeleitet ohne das ich die install.pl seite überhaupt irgendwie zusehen bekomme.

          • #15133
            Daniel Leidenheimer
            Participant

              Oh man ich bin ein Idiot :D

              ich hab die ganze Zeit install.pl versucht aufzurufen anstatt installer.pl.

              Ich weis auch nicht warum ich die ganze zeit die falsche Datei aufgerufen hab.

            • #15134
              marcel-graf
              Participant

                Hallo Daniel,

                na dann viel erfolg beim weiteren einrichten.

                Gruß Marcel

            Viewing 4 reply threads
            • You must be logged in to reply to this topic.