Viewing 2 reply threads
  • Author
    Posts
    • #15451
      Oliver Stähr
      Participant

        Hallo Community,

        ich habe eine frische 10.1.7 Installation mit ITSM und darunter Elasticsearch 8.8.2.
        Die Computerklasse hat u.a. eine interne Inventarnummer bekommen, nach der ich gerne per Elasticsearch suchen möchte. Oder auch nach dem Owner.

        Es ist aber egal, was ich unter Elasticsearch::ConfigItemSearchFields und/oder Elasticsearch::ConfigItemStoreFields eintrage, es wirkt sich nicht auf den Elasticsearch Index aus. Maint::Elasticsearch::Migration läuft natürlich nach jeder versuchsweisen Änderung.

        So wie unten sieht der effektive Index immer aus, wobei die CurDeplStateID in den ConfigItem(Search/Store)Fields gar nicht auftaucht, aber im Index ist.

        Bin ich da auf dem Holzweg oder übersehe ich was?

        VG Olli


        curl -X GET "localhost:9200/configitem/_mapping"

        {
        “configitem”: {
        “mappings”: {
        “properties”: {
        “Class”: {
        “fields”: {
        “keyword”: {
        “ignore_above”: 256,
        “type”: “keyword”
        }
        },
        “type”: “text”
        },
        “ClassID”: {
        “type”: “integer”
        },
        “ConfigItemID”: {
        “type”: “integer”
        },
        “CurDeplStateID”: {
        “type”: “integer”
        },
        “Name”: {
        “fields”: {
        “keyword”: {
        “ignore_above”: 256,
        “type”: “keyword”
        }
        },
        “type”: “text”
        },
        “Number”: {
        “fields”: {
        “keyword”: {
        “ignore_above”: 256,
        “type”: “keyword”
        }
        },
        “type”: “text”
        }}}}}

      • #15455
        Stefan Abel
        Moderator

          Hallo,

          ich glaube, du musst nur in der Systemkonfiguration unter Elasticsearch::ConfigItemSearchFields eine neue Zeile unter XML hinzufügen und dort dann bspw. Feldname::1 eintragen und danach den Index neu aufbauen mit bspw. bin/otobo.Console.pl Maint::Elasticsearch::Migration -i

          Ich bin mir aber gerade auch unsicher, ob da noch irgendwo der Klassenname rein muss. Probiere es doch so mal aus. Ich hoffe, das hilft weiter.

          Viele Grüße
          Stefan

        • #15456
          Oliver Stähr
          Participant

            Hi Stefan,

            danke, das war der entscheidende Hinweis. Ist ja auch offensichtlich, dass die “internen” Felder unter Basic stehen und zusätzliche dann unter XML reingehören … nicht. :-)

            Wer auf das gleiche Problem stößt:

            Unter Elasticsearch::ConfigItemSearchFields nur den Array XML mit gewünschten Feldern (den Key) aus der CI Definition ergänzen und mit ::1 dahinter versehen: z.B. EigenesFeld::1

            In der Ergebnisansicht lassen sich die Spalten auch verändern, unter Elasticsearch::QuickSearchShow###ConfigItem ergänzen: AttributeHeader -> Key::1 -> Freitext und Attributes -> Key::1

             

            Trotzdem bleibt die CurDeplStateID im Index, obwohl sie in der Config nicht auftaucht. Aber das ist mir auch wurscht.

            VG Olli

        Viewing 2 reply threads
        • You must be logged in to reply to this topic.