Viewing 3 reply threads
  • Author
    Posts
    • #12896
      Marco Biermann
      Participant

        Hallo zusammen,

        bei einem Blick ins Log ist mir aufgefallen, dass ich alle paar Minuten folgenden Fehler habe:

        (Fehlermeldung angepasst, da ich sie sonst nicht posten kann)

        Error while performing REST POST request to Controller / ticket/ _update/ 40 on Host http: // localhost : 9200. Response code 500

        Laut diverser Elasticsearch Forenbeiträgen so das Ändern des network hosts auf „127 . 0 . 0 . 1“ in der / etc/ elasticsearch/ elasticsearch . yml Abhilfe schaffen.

        Bei mir jedoch leider nicht. Was ist hier genau der Fehler und wie löse ich ihn?

        Vielen Dank vorab!

      • #12914
        Mario Sch
        Participant

          Läuft dein ElasticSearch Webservice noch?

          Mein ist anfangs öfter gecrashed und ich habe den Speicher erhöht.

          Du kannst mal mit sudo systemctl status elasticsearch prüfen ob der service noch läuft

          • #12933
            Marco Biermann
            Participant

              Der Service läuft nicht und kann auch nicht gestartet werden.

              systemd[1]: elasticsearch.service: A process of this unit has been killed by the OOM killer.
              systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL
              systemd[1]: elasticsearch.service: Failed with result ‚oom-kill‘.
              systemd[1]: Failed to start Elasticsearch.

              Mir ist aufgefallen, dass ich den letzten Schritt „Elasticsearch Configuration“ nicht durchgeführt hatte.

              Sobald ich die Setting mit 4GB aktiviere erhalte ich zusätzlich die Meldung, dass nicht genügend Speicher zur Verfügung steht, macht auch Sinn, weil die VM derzeit auch 4GB RAM hat

              OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000006c0000000, 4294967296, 0) failed; error=’Not enough space‘ (errno=12)

              -> Auch wenn ich nur 1GB zuweise erhalte ich die erste Fehlermeldungen ganz oben

               

              Ich habe bei der Gelegenheit auch mal elasticsearch neu installiert:

              sudo apt-get install –reinstall elasticsearch

              Leider auch nicht erfolgreich:

              OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000006c0000000, 4294967296, 0) failed; error=’Not enough space‘ (errno=12)

            • #12934
              Mario Sch
              Participant

                ich hatte das gleiche Problem.

                Habe die VM auf 8GB erhöht und ElasticSearch auf 4GB. Seit dem läuft es ohne OOM (Out of memory).

                Man sollte nie mehr als die die Hälfte des RAMs für den Heap verwenden. Du kannst noch 2GB probieren.

            • #12954
              Marco Biermann
              Participant

                Die Ressourcen der VM zu erhöhen hat im ersten Anlauf nicht geholfen.

                Nach einem Blick in das elasticsearch.log fiel mir auf, dass die Versionen zweier Plugins nicht passten:

                Plugin [analysis-icu] was built for Elasticsearch version 7.16.3 but version 7.17.1 is running

                Plugin [ingest-attachment] was built for Elasticsearch version 7.16.3 but version 7.17.1 is running

                Dafür muss das Plugin jeweils einmal entfernt und wieder hinzugefügt werden:

                sudo /usr/share/elasticsearch/bin/elasticsearch-plugin remove analysis-icu

                sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install analysis-icu

                Anschließend konnte ich den Service starten.

                Vielen Dank für die Unterstützung!

                Nur damit ich einen Vergleich habe, welche Ausstattung haben Eure VMs und was ist der Best-Practise für die Speicherzuweisung von Elasticsearch?

              • #12969
                Marco Biermann
                Participant

                  Nachtrag, neuer Fehler:

                  Error while performing REST 'POST' request to Controller '/ticket/_search' on Host 'http://localhost:9200'. Response code '400' Response content: '{"error":{"root_cause":[{"type":"query_shard_exception","reason":"No mapping found for [Created] in order to sort on","index_uuid":"xxxxxxxxxxxxxxxx","index":"ticket"}]

                  Der Service läuft und zieht sich auch ordentlich Arbeitsspeicher rein.

                  Ich bin hier leider ratlos..

              Viewing 3 reply threads
              • You must be logged in to reply to this topic.