Viewing 2 reply threads
  • Author
    Posts
    • #14070
      tommaso iovane
      Participant

        HI, im trying to populate a dynamic field in AgentTicketFreeText through a webservice. This is the endpoint https://progeta-sinapto.sinapto.tech/static/test.php, it’s a software we work on, so we have full control of what it sends to otobo, atm is sending:

        {"Data":{"Key":"Data","Value":"Value"}}

        the webservice on otobo is configured as following:

        the invoker’s event triggers are TicketCreate, TicketTitleUpdate.

        In the webservice’s debugger section i can see that otobo can reach the endpoint and parse the data as following:

        $VAR1 = {
        'Data' => {
        'Key' => 'Data',
        'Value' => 'Value'
        }
        };

        even so, in the ticket’s AgentTicketFreeText the dynamic field appears either as a disabled input field or as a text “DynamicField/Agent/WebService.tt”.

        Is my endpoint sending the data the wrong way? thanks for help!

      • #16433
        Jürgen Neyses
        Participant

          Hi Tamasso, I am facing the same issue with 10.1. I have configured the dynamic field and connected it to a REST service. The service gets called and I can see in the debugger, that the value is retrieved by the service and mapped. But I am getting an disabled dynamic field with content: DynamicField/Agent/WebService.tt. So I expect the JSON response is in the wrong format.

          Has anyone some documentation on the use of webservices on dynamic fields? Unfortunately the official documentation is still not populated. Thanks for help.

        • #16442
          Private Reply
          Anonymous
            This reply has been marked as private.
        Viewing 2 reply threads
        • You must be logged in to reply to this topic.