Topic Resolution: Answered
Viewing 2 reply threads
  • Author
    Posts
    • #15651
      Answered
      tomi tomi
      Participant

        Im trying to create filter to limit users in Otobo  to active users from my AD  with email addres , but I coudn’t find correct condition

        $Self->{'Customer::AuthModule::LDAP::AlwaysFilter1'} = '(&(objectclass=user)(mail=*@mydomain.com)( ??USER IS ENABLE ???))';

         

      • #15652
        Best Answer
        marcel-graf
        Participant

          Hello tomi,

          in our ldap test(not used actually) we use the following filter:

          AlwaysFilter => ‘(&(objectCategory=person)(objectClass=user)(!(userAccountControl:1.2.840.113556.1.4.803:=2))(mail=*)(sn=*)(givenname=*)(!(givenname=\00)))’

          “(!(userAccountControl:1.2.840.113556.1.4.803:=2))”  = not disabled

          (!(givenname=\00)) =  i think, it was givenname is not null

           

          http://www.selfadsi.org/ads-attributes/user-userAccountControl.htm

           

          KR, Marcel

        • #15663
          tomi tomi
          Participant

            Thank you very much it is a perfect answer

            $Self->{'Customer::AuthModule::LDAP::AlwaysFilter1'} = '(&(objectclass=user)(mail=*@mydomain.com)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))';
        Viewing 2 reply threads
        • You must be logged in to reply to this topic.