Viewing 1 reply thread
  • Author
    • #13503
      Eldaras Sad


        I changed value in HTTPSForceRedirect check to Enabled.

        Now I get the two error:

        [Notice][Kernel::System::Web::InterfaceAgent::Run] HttpType https is set, but http is used!
        How to reset HTTPSForceRedirect the value?

        [Error][Kernel::System::Web::InterfaceAgent::Run][Line:206]: Can’t connect to MySQL server on ‘127.0.o.1’
        docker exec -it otobo_db_1 mysql -u otobo -p
        I connect to otobo database  without a problem.
        /var/lib/docker/volumes/otobo_opt_otobo/_data/Kernel/ :
        DatabaseHost = ‘db’;
        DatabaseUser: otobo
        DatabasePw: same password

        DatabaseHost = ‘’;
        DatabaseUser: otobo
        DatabasePw: same password

        I tried to rebuild, but got error:
        su -c “bin/ Maint::Cache::Delete” -s /bin/bash otobo
        su -c “bin/ Maint::Config::Rebuild –cleanup” -s /bin/bash otobo DBI connect(‘database=otobo;host=;’,’otobo’,…) failed: Access denied for user ‘otobo’@’localhost’ (using password: YES) at /opt/otobo/Kernel/System/ line 331.

        The database login details are correct. Why am I getting an error?


      • #13505
        Stefan Rother

          Hi Eldaras,

          first of all, your OTOBO configuration is not right. Please go to
          and reinstall OTOBO again, that was the easiest way.

          Anyway, you need to have the same file if you open it inside the container or outside? is not right, please you “db”.

          If you use HTTPSForceRedirect please be sure to configure OTOBO with HTTPS and also use the config option HTTPType = HTTPS inside OTOBO.

          Config rebuild can’t help, because it’s not a reset, it only think the config from database again.

          I wish you a nice evening,

          Team OTOBO

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.