Viewing 2 reply threads
  • Author
    Posts
    • #9118
      Michael
      Participant

      Hallo,

      ich habe aktuell ein Problem, dass die Kundennummer (CustomerID) nicht gefüllt wird, wenn ich als Agent über ein neues Telefon-Ticket ein Ticket erstelle. Wenn ich im Kundenfrontend oder per Email ein Ticket erstelle funktioniert es wie erwartet.

      Das Ganze kann ich auch über Ihr Demosystem nachstellen. Wenn ich dort einen bestehenden Kundenbenutzer (mit einem entsprechenden Kunden) auswähle, wird die Info zwar in der Infoansicht korrekt dargestellt, es wird aber keine Kundennummer hinterlegt:

      Speichere ich nun das neue Ticket, so ist das Feld „Kundennummer“ leer.

      Bei meiner lokalen Installation ist das verhalten exakt genauso. Ist dies gewünscht und „by design“ oder handelt es sich um einen Bug?

    • #9122
      Sven Oesterling
      Keymaster

      Hallo Michael,

      es handelt sich um einen bug – danke für’s Bescheid geben. Ich habe das ganze schon behoben, mit 10.0.5 wird es draußen sein. Wenn du das früher schon anders brauchst, könntest du dir die folgenden beiden Dateien herunterladen und in deinem System ersetzen (rechte Maustaste auf „Raw“, rechts über dem Code, und dann „Speichern unter“):

      https://github.com/RotherOSS/otobo/blob/0865ed1ebfb770b308fec11c828eba89eae0159d/Kernel/Output/HTML/Templates/Standard/AgentTicketEmail.tt
      https://github.com/RotherOSS/otobo/blob/0865ed1ebfb770b308fec11c828eba89eae0159d/Kernel/Output/HTML/Templates/Standard/AgentTicketPhone.tt

      Du müsstest dabei auf die Rechte achten, und nach dem Ersetzen aufjedenfall in /opt/otobo einmal

      bin/otobo.Console.pl Maint::Cache::Delete

      ausführen. (Den webservice zu reloaden ist vllt auch eine gute Idee.) Alternativ ginge, in der Sysconfig Ticket::Frontend::AgentTicketPhone::CustomerIDReadOnly und das gleiche für Email zu deaktivieren, temporär.

      Viele Grüße, Sven

    • #9127
      Michael
      Participant

      Hi Sven,

      Danke für die Info! Ja ich habe die Änderungen direkt eingepflegt, jetzt geht es wieder wie gewollt :-) Vielen Dank für die schnelle Hilfe!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.