Tagged: 

Viewing 13 reply threads
  • Author
    Posts
    • #14857
      Simon Bisinger
      Participant

        Hallo zusammen,

         

        Ich habe OTOBO (V10.0.17) mit Docker und NGINX als Reverse Proxy und einem Selfsigned SSL-Zertifikat auf einer Ubuntu VM installiert. Das System läuft so weit, jedoch habe ich Performance Probleme.

        VM-Ressourcen: 3Kerne Intel(R) Xeon(R) Gold 6134 CPU @ 3.20GHz

        16 GB DDR4 RAM

        100 GB SSD-Speicher

         

        Wie zu sehen, sind die durchschnittlichen Antwortzeiten zu hoch, um Spaß beim Arbeiten zu haben.

         

        Die Server Auslastung ist jedoch nicht das Problem wie oben zu sehen. Die CPU Auslastung lag bisher maximal bei 30 % pro Kern und der RAM hatte eine maximale Auslastung von 5 GB.

        Kennt jemand dieses Problem und weiß eine Lösung dafür?

         

        Viele Grüße

        Simon

      • #14859
        Man Cheung Ip
        Participant

          Hi Simon,

          ich bin zwar selbst noch dabei OTOBO zu installieren (Migration von OTRS), aber schau dir mal bitte den Beitrag an:

          https://doc.otobo.de/manual/installation/10.0/de/content/performance-tuning.html

          Auf

          Was du noch probieren kannst, ist deine Datenbank anzupassen. Ich kann allerdings nur Erfahrungen mit MySQL/MariaDB teilen. Solltest du MariaDB nutzen, so überprüf mal, ob deine Datenbank überhaupt genug RAM nutzen darf, ohne dass er ständig sich selbst limitiert. Stichworte dahingehend sind sowas wie innodb_buffer_pool_size oder _logfile_size. Es gibt auch nützliche Tools, die dir Einstellungen empfehlen.

          Dann kannst du noch die NGINX Einstellungen anpassen.

           

          Viele Grüße

          Manni

          • #14872
            Simon Bisinger
            Participant

              Hi Manni,

              Danke für deine schnelle Antwort!

               

              Kannst du mir sagen, wo ich die Konfig Datei der DB finde? Ich benutzte übrigens MySQL und MariaDB.

              Die Doku konnte mir leider nicht weiterhelfen.

               

              Viele Grüße

              Simon

               

               

          • #14873
            Man Cheung Ip
            Participant

              Hi Simon,

               

              Ich kenne mich mit docker nicht so gut aus, in der Regel liegt aber die Config unter /var/mysql/maria.conf.d/50-server

              Bitte such mal nach mysqltuner

               

              Viele Grüße

              Manni

              • #14883
                Simon Bisinger
                Participant

                  Hi Manni,

                   

                  ich habe jetzt nach langem Suchen die Datei gefunden und die Werte angepasst, leider keine Besserung.

                  Jedoch ist mir was aufgefallen, was die langsame Verarbeitung erklären könnte, und zwar versucht das Ticketsystem ca. 4000 Mails an root@localhost zu senden. Diese können aber nicht versendet werden und brechen aber auch nicht ab, kennst du da zufällig eine Lösung? Ich denke das durch diesen Mailversand Loop das ganze System verlangsamt wird.

                  Ich habe schon den Terminal Befehl  “bin/otobo.Console.pl Maint::Email::MailQueue –send” ausprobiert, jedoch findet er bei mir den Pfad nicht.

                  Viele Grüße

                  Simon

                   

              • #14887
                Man Cheung Ip
                Participant

                  Hi Simon,

                  dann bitte mal die Option Daemon::SchedulerTaskWorker::NotificationRecipientEmail die Mailadresse ändern.

                  Alternativ die Mailbox für root@localhost lokal auf der Maschine einrichten, dann ist das Problem zwar gelöst aber dein Mailbox wird irgendwann mehr als voll und diese Option sollte nur als Test dienen.

                  Des Weiteren, bitte nicht mit dem Standard root/admin Account auf OTOBO arbeiten.

                   

                  Viele Grüße

                  Manni

                  • #14888
                    Simon Bisinger
                    Participant

                      Hi Manni,

                       

                      gibt es auch die Möglichkeit die E-Mails aus der DB direkt zu löschen?

                      Ich will nicht riskieren von O365 als Spam Domain markiert zu werden wenn 4500 mails auf einmal versand werden.

                       

                      Viele Grüße

                      Simon

                  • #14889
                    Man Cheung Ip
                    Participant

                      Hi Simon,

                      auf der Shell-Ebene kannst du dir mit dem folgenden Befehl die MailQueue anschauen (ggf. Pfad und Benutzer anpassen):

                      su -c "/opt/otobo/bin/otobo.Console.pl Maint::Email::MailQueue --list" -s /bin/bash otobo

                      Mit der Option –delete-all kannst du alle Mails in der Warteschlange löschen. In Zusammenhang mit einem Filter kannst du auch mit –delete und –filter bestimmte Mails auflisten und löschen. So müsste der folgende Befehl für dich passen (ungetestet):

                      su -c "/opt/otobo/bin/otobo.Console.pl Maint::Email::MailQueue --list --filter==Recipient::root@localhost" -s /bin/bash otobo

                       

                      Viele Grüße

                      Manni

                    • #14923
                      Simon Bisinger
                      Participant

                        Hi Manni,

                         

                        Ich hab das ganze System jetzt nochmal neu aufgesetzt und siehe da es läuft um Welten besser.

                        Jedoch hab ich jetzt das Problem, das keine E-Mails versendet werden, wenn z.B. ein Ticket erstellt wird .

                         

                        In der Systemkonfig habe ich

                        SendmailModule

                        SendmailModule::AuthPassword

                        SendmailModule::AuthUser

                        SendmailModule::Host

                        SendmailModule::Port

                        angepasst und unter Kommunikation & Benachrichtigungen eine System E-Mail Adresse hinterlegt.

                        Im Kommunikationsprotokoll bleiben die Mails jedoch an Punkt 5 “Kernel::System::Email” Successfully queued message for delivery hängen.

                         

                        Hast du da vielleicht auch einen Tipp?

                         

                        Viele Grüße

                        Simon

                      • #14925
                        Man Cheung Ip
                        Participant

                          Hi Simon,

                          schau mal bei Admin und Kommunikationsprotokoll, was da nun steht. Ggf. das Sendemodul ändern.

                          • #14927
                            Simon Bisinger
                            Participant

                              Hi Manni,

                              ich habe schon SMTP, SMTPS und SMTPTLS probiert und immer es ist immer das gleiche Kommunikationsprotokoll

                              Die anmelde Daten habe ich auch kontrolliert. Die Einstellungen sind eigentlich gleich wie in dem “langsamen” alten System und dort hat der Mailversand funktioniert.

                              Viele Grüße

                              Simon

                          • #14928
                            Man Cheung Ip
                            Participant

                              Was sag denn dein syslog dazu?

                              • #14930
                                Simon Bisinger
                                Participant

                                  Das syslog in der Weboberfläche ist leer, ich habe aber gerade die Logs vom otobo_daemon Container dursucht und da gibt es eine Zeile ” No configured mail accounts found! Proccessing ticket escalation events … Done.”

                              • #14933
                                Man Cheung Ip
                                Participant

                                  Schau doch mal bitte, ob du bei Admin -> E-Mail-Adressen deine Mailadresse auch eingetragen ist.

                                  • #14934
                                    Simon Bisinger
                                    Participant

                                      Dort habe ich die Default Adresse durch meine E-Mail ersetzt.

                                  • #14935
                                    Man Cheung Ip
                                    Participant

                                      Da sollte die gleiche Mailadresse drin stehen wie bei PostMaster und entsprechend in der Queue auch.

                                    • #14937
                                      Simon Bisinger
                                      Participant

                                        Hi Manni, ich hab jetzt nochmal alles getestet. https://otobo.de/de/forums/topic/smtps-modul-hat-ploetzlich-aufgehoert-zu-funktionieren/

                                        Mit den Befehlen aus dem Beitrag wurden dann E-Mails versendet, jedoch nicht die, die versendet werden sollten.

                                         

                                        Davon sind so knapp 1800 Mails bei mir im Postfach gelandet, bevor ich den otobo_daemon gestoppt habe. Ich verstehe jetzt aber nicht, warum mir keine Ticket Benachrichtigungen gesendet werden, aber die Fehlermeldungen gehen raus. Das ganze ergibt für mich wenig Sinn.

                                      • #14941
                                        Man Cheung Ip
                                        Participant

                                          Das ist schon sehr komisch, man müsste im Log mal nachschauen, woran es hängt. Was für einen Maildienst nutzt du denn? Intern Exchange?

                                        • #14944
                                          Simon Bisinger
                                          Participant

                                            Wir benutzen den Exchange Online Plan. Wo finde ich die logs für den E-Mail Versand dann kann ich mal nachschauen.

                                          • #14946
                                            Man Cheung Ip
                                            Participant

                                              Eigentlich müsstest du im Kommunikationslog alle Schritte sehen. Achte dabei auf den Zeitstempel, da auch vergangene Fehler noch angezeigt werden. Überprüf doch nochmal bitte deine Maileinstellungen.

                                          Viewing 13 reply threads
                                          • You must be logged in to reply to this topic.