Topic Resolution: Resolved
Viewing 2 reply threads
  • Author
    Posts
    • #11730
      Daniel Bähr
      Participant

      Hallo zusammen,

      wir haben bislang OTRS eingesetzt und sind aktuell dabei eine Migration auf OTOBO 10.0.11 durchzuführen. Kurz zum Szenario:

      • OTRS-Version = 6.0.30
      • OTOBO-Zielversion = 10.0.11
      • OTOBO wird auf dem gleichen Server installiert, auf welchem auch schon OTRS betrieben wird
      • Server OS = openSUSE Leap 15.2

      Folgendes wurde gemacht:

      • OTOBO wurde parallel zum OTRS installiert (verwendet einfach andere Ports im Apache)
      • Perl-Module wurden geprüft und aktualisiert
      • Anmeldung im leeren neuen OTOBO mittels root@localhost war möglich > alles gut soweit
      • Migration mittels migration.pl gestartet und erfolgreich abgeschlossen (Schritt 5/5 meldete erfolgreichen Abschluss)

      Danach konnten wir uns im OTOBO anmelden. Ein Aufruf eines Tickets meldete allerdings den Fehler, dass der User root@localhost nicht ausreichend Rechte besitzt. Daraufhin haben wir die Apache-Config erweitert um den SSO-Teil (Kerberos) und den Apache neugestartet.

      Seitdem können wir uns nicht mehr im OTOBO anmelden, es kommt immer folgende Fehlermeldung: „Sie verwenden leider einen (stark) veralteten Webbrowser“

      Das Entfernen der SSO-Änderung in der Apache-Konfig bringt keine Änderung. Auch das Anpassen der Config.pm zeigt keine Änderung des Verhaltens. Im Systemlog und Error-Log von Apache sind keine Fehler zu finden.

      Wir haben es mit 3 aktuellen Browsern getestet (Chrome, Edge, Firefox) und bei allen kommt diese Meldung. Zudem hatten wir die Migration vorher auf einem anderen Server getestet und dort ist das Problem nicht aufgetreten (war allerdings auch eine fast leere OTRS-Installation).

      Hat das schon mal jemand gehabt bzw. kennt jemand die Ursache für das Verhalten?

      Viele Grüße
      Daniel

    • #11741
      Sven Oesterling
      Keymaster

      Hallo Daniel,

      da läuft das JavaScript nicht richtig. (Überprüfen lässt sich das in der Konsole im Browser.)

      Mein Hauptverdächtiger ist das jquery-validate, das wir in OTOBO 10.0.10 geupdated haben. Da kann es sein, dass wegen händischen Änderungen, oder einem Paket das du installiert hast, die SysConfig-Option Loader::Agent::CommonJS nicht mit auf den aktuellen Stand gebracht wurde und eine alte, nicht existierende Version beinhaltet. Mach doch bitte mal ein:

      grep 'jquery-validate' /opt/otobo/Kernel/Config/Files/ZZZAAuto.pm

      Wenn die Version da nicht 1.19.3 ist, pass das als temporären Fix in genau dieser Datei an. Dann solltest du auf das System kommen und es da in der SysConfig nachholen können. (Für die Customer::CommonJS ebenfalls.)

      Falls das nicht das Problem ist, müsstest du tatsächlich in deiner Browser-Konsole mal gucken, was da los ist.

      Viele Grüße, Sven

    • #11748
      Daniel Bähr
      Participant

      Hallo Sven,

      das hat geholfen, vielen Dank. In der Systemkonfiguration stand noch jquery-validate-1.16.0 drin, nach der Anpassung auf jquery-validate-1.19.3 kam die Meldung bzgl. des veralteten Browsers nicht mehr.

      Danach klappte die Anmeldung allerdings immer noch nicht, die Fehlermeldung war diesmal JavaScriptError: Core.UI.Elasticsearch is undefined. Ich habe daraufhin ebenfalls in der ZZZAAuto.pm in den Bereichen

      • {‚Loader::Agent::CommonJS‘}->{‚000-Framework‘}
      • {‚Loader::Customer::CommonJS‘}->{‚000-Framework‘}

      zusätzlich Core.UI.Elasticsearch.js eingefügt. Seitdem funktioniert die Anmeldung fehlerfrei und das Dashboard lädt.

      Vielen Dank für deine schnelle Hilfe.

      Viele Grüße
      Daniel

Viewing 2 reply threads
  • You must be logged in to reply to this topic.