Tagged: 

Viewing 3 reply threads
  • Author
    Posts
    • #13662
      J L
      Participant

      Hallo zusammen,

      wir haben momentan eine Test Migration von OTRS zu OTOBO durchgeführt und wollten uns jetzt um die Mailauthentifizierung mit OAuth kümmern. Leider funktioniert die Abholung der Mails nicht, im Log kommt folgender Fehler:

      Something went wrong while trying to connect to ‚IMAPOAuth2 => mymailbox@my-domain.com/outlook.office365.com‘: Can’t call method „authenticate“ on an undefined value at /opt/otobo/bin/psgi-bin/../../Kernel/System/MailAccount/IMAPOAuth2.pm line 83

      In der Zeile 83 des Scripts geht es glaube ich um die Rückgabe des Bearer Tokens.

      Was bisher konfiguriert wurde:

      • App registration in Azure angelegt und die benötigten Berechtigungen erteilt, mit Admin Consent
      • Das OAuth Profil in OTOBO entsprechend konfiguriert mit App ID und Secret
      • Beim Speichern des Mailaccounts kommt auch der Microsoft Login und nach PW Eingabe werde ich zurück zur MailAccount-Übersicht geleitet und es kommt die Meldung „Mailaccount updated“.
      • Bei FetchMail erscheint dann die o.g. Fehlermeldung im Log.

      Irgendwo habe ich gelesen dass man den OAuth Provider anpassen muss indem man seine Azure Tenant ID in die URLs einfügt, hat aber auch nicht geholfen, die Fehlermeldung bleibt die gleiche.

      Hat vielleicht jemand eine Idee was das Problem sein könnte?

      Danke & Grüße

    • #13776
      marcel-graf
      Participant

      Hallo,

      wir haben bei uns in der Systemconfig folgendes eingetragen:

      1. Profil definieren mit ClientID & ClientSecret 2. die Provider Settings (siehe Bild)

      Dann in den Email Konten das Konto auf OAuth2 (bei uns IMAPOAuth2) geändert und Microsft Azure Profile ausgewählt. Nach dem speichern und Abschließen wird man ja zum Login auf der Microsft Website aufgefordert. Danach geht eine Bestätigungsseite auf und das Konto ist fertig konfiguriert. Nutzt man nun hier Http bei seinem Server, muss man in der Bestätigungswebseite das https in http ändern, dann sollte das klappen.

      Das Konto sollte auch für IMAP freigeschaltet sein.

      Aktuell nutzen wir die Otobo Version 10.1.5 haben OAuth2 aber auch schon bei der 10.1.4 genutzt.

      Vielleicht hilft das ja weiter.

      Gruß Marcel

    • #14010

      Hallo JL,

      hat sich das Problem inzwischen gelöst? Wenn ja, was war die Lösung?

      Ich habe hier das gleiche Fehlerbild, allerdings mit einer Shared-Mailbox in M365 die ich via „IMAPOAuth2“ aubrufen möchte. Siehe auch hier.

    • #14011
      Grit Rother
      Keymaster

      Habt ihr gesehen, dass die Doku Ende Sept nochmal ergänzt wurde?

      Vielleicht findet sich da ja etwas:
      https://doc.otobo.org/manual/admin/10.1/en/content/communication-notifications/postmaster-mail-accounts.html#otobo-oauth2-configuration

       

Viewing 3 reply threads
  • You must be logged in to reply to this topic.