Viewing 2 reply threads
  • Author
    Posts
    • #12807
      Michael R
      Participant

      Hallo zusammen,

      ich versuche gerade OAuth2 für Google Workspace einzurichten.

      Habe unter OTOBO 10.1.1 das Paket MailAccount-OAuth2 installiert und die entsprechenden OAuth2-Parameter gepflegt.

      Bei der Konfiguration des Mail-Accounts (Profil IMAOOAuth2) klappt die Verbindung zu Google, allerdings meldet die API einen Fehler:

      https://accounts.google.com/signin/oauth/error?authError=...
      Error 400: invalid_request

      Missing required parameter: redirect_uri

      Google scheint diesen Parameter (obligatorisch) zu erwarten (siehe auch https://developers.google.com/identity/protocols/oauth2/web-server).

      Kann es sein, dass OTOBO diesen Parameter nicht übermittelt?

      Viele Grüsse und danke für Eure Hilfe,
      Michael

       

    • #12816
      zzz
      Participant

      Hallo Michael,

      könntest Du die generierte URL anpassen und an das Ende noch folgendes dranhängen ‚&redirect_uri=https://domain.com/otobo/index.pl?Action=AdminMailAccount‘?

      *domain.com durch die eigene FQDN ersetzen.

      Viele Grüße
      Emin

      • #12838
        Michael R
        Participant

        Hallo Emin,

        danke für Deine Antwort.

        Leider kann ich die „generierte URL“ nicht anpassen, ohne ins Coding einzugreifen.

        Beim Abspeichern des Mail Accounts wird eine Anfrage an Google geschickt, die man manuell nicht beinflussen kann. Als Rückmeldung kommt dann die URL https://accounts.google.com/signin/oauth/error?authError=...

        Der Parameter für die redirect_uri ist auch in der Systemkonfiguration und in den Programmen nicht vorgesehen.

        Viele Grüsse
        Michael

    • #12971
      Michael R
      Participant

      Kann mir niemand zu diesem Thema weiterhelfen?

      Viele Grüsse
      Michael

      • #13293
        Pablo Gabriel
        Participant

        Hallo;
        Ich habe das gleiche Problem
        konntest du es reparieren?

Viewing 2 reply threads
  • You must be logged in to reply to this topic.