Tagged: , ,

Viewing 1 reply thread
  • Author
    Posts
    • #10433
      Markus Lembke
      Participant

        Hi,

        I’ve a little Problem regarding my Backup.
        I’ve followed the Article, but if i execute the Bakup command, i always get that error.

        —->

        root@srvotobo01:/opt/otobo-docker# docker run -it –rm –volume otobo_opt_otobo:/opt/otobo –volume otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest scripts/backup.pl -d /otobo_backup
        Backup /otobo_backup/2021-01-01_10-49/Config.tar.gz … done
        Backup /otobo_backup/2021-01-01_10-49/Application.tar.gz … done
        Dumping mysql data to /otobo_backup/2021-01-01_10-49/DatabaseBackup.sql.gz …
        mysqldump: Error 2020: Got packet bigger than ‘max_allowed_packet’ when dumping table package_repository at row: 1
        failed
        Deleting incomplete backup /otobo_backup/2021-01-01_10-49 … done
        [Fri Jan 1 10:49:55 2021] backup.pl: Backup failed at /opt/otobo/scripts/backup.pl line 322.

        <—-

        I’ve installed the folowing Packages

        • ITSM,
        • FAQ,
        • Survey,
        • Master/Slave,
        • ImportExport,
        • GeneralCatalog

        As i understand the Error correctly, it depands on the My.cf and there the Section [mysqldump].
        In the dockcker-compose file, there is a Command

        —>
        command: –max-allowed-packet=134217728 –character-set-server=utf8mb4 –collation-server=utf8mb4_unicode_ci –innodb-log-file-size=268435456
        <—

        I’ve increased the Value, but it dosn’t solve my Problem.

        So hope you can help.

        Best Regards,

        Markus

      • #10551
        Stefan Rother
        Keymaster

          Hi Markus,

          I hope you are well!

          Please excuse the late reply, we are currently a bit stretched with answering OTOBO related queries on all channels.

          You need to set the mysql/mariadb setting max_allowed_package higher (at least 64MB). In your case it’s possible to set this value directly inside the backup.pl script:

          otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest scripts/backup.pl –max-allowed-packet=64000000 -d /otobo_backup

          Best wishes from Germany,

          Stefan Rother

          Team OTOBO

          • #10572
            Markus Lembke
            Participant

              Hi Stefan,

              i’ve tried it, but with no luck.

              ->

              root@srvotobo01:/opt/otobo-docker# docker run -it –rm –volume otobo_opt_otobo:/opt/otobo –volume otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest scripts/backup.pl –max-allowed-packet=256000000 -d /otobo_backup
              Backup /otobo_backup/2021-01-17_16-56/Config.tar.gz … done
              Backup /otobo_backup/2021-01-17_16-56/Application.tar.gz … done
              Dumping mysql data to /otobo_backup/2021-01-17_16-56/DatabaseBackup.sql.gz …
              mysqldump: Error 2020: Got packet bigger than ‘max_allowed_packet’ when dumping table package_repository at row: 1
              failed
              Deleting incomplete backup /otobo_backup/2021-01-17_16-56 … done
              [Sun Jan 17 16:57:00 2021] backup.pl: Backup failed at /opt/otobo/scripts/backup.pl line 322.

              <–

              I’ve used to set it to 256MB, but it dosn’t help.
              How do i set this Parameter directly in mysql/mariadb?

              Best regards,

              Markus

        Viewing 1 reply thread
        • You must be logged in to reply to this topic.