Viewing 0 reply threads
  • Author
    Posts
    • #15554
      Mirco W.
      Participant

        Hallo zusammen,

        aktuell möchten wir gerne zwei Otobo-Systeme auf einem Server laufen lassen. Dazu konfiguriere ich Virtual Hosts in den Config-Dateien vom Apache Server. Ich habe bereits ein zweites Otobo auf dem Server heruntergeladen aber kann das noch nicht erreichen, da ich immer bei dem ersten lande.

        Hier der Auszug aus der Config-Datei für das zweite Otobo System:

        <VirtualHost otobo-vhost.xxx:443>

        # Please change here the otobo admin mail address
        ServerAdmin xxxx

        # Please change here the FQDN or hostname, you like to use with OTOBO
        ServerName otobo-vhost.xxx

        # Please change here and add more different FQDN´s or hostnames, you like to use with OTOBO
        #ServerAlias xxxx

        HostnameLookups Off
        UseCanonicalName Off
        ServerSignature Off

        <IfModule mod_ssl.c>

        # Please load the ssl module before (On most linux systems use: “bash> a2enmod ssl”)
        SSLEngine on

        # Please add the path to the ssl cert
        SSLCertificateFile /etc/ssl/certs/xxxx

        # Please add the path to the ssl key
        SSLCertificateKeyFile /etc/ssl/private/xxxx

        # Please add the path to the ssl chain file (Download from used ssl cert publisher)
        #SSLCertificateChainFile /etc/ssl/certs/linux_intermediate_otobo.ch.pem

        </IfModule>

        # mod_perl is required
        <IfModule !mod_perl.c>
        Error “mod_perl is required for Plack::Handler::Apache. Use apache2-httpd-cgi.include.conf as fallback.”
        </IfModule>

        <IfModule mod_perl.c>

        <IfModule mpm_event_module>
        Error “The Multi-Processing Module mpm_event is active but it isn’ supported by OTOBO. Please switch to mpm_prefork.”
        </IfModule>

        <IfModule mpm_worker_module>
        Error “The Multi-Processing Module mpm_worker is active but it isn’t supported by OTOBO. Please switch to mpm_prefork.”
        </IfModule>

        # Use a dedicated Perl interpreter for the current virtual host, in this case the virtual host serving port 443
        PerlOptions +Parent

        # Preload otobo.psgi so that that the app doesn’t have to be loaded again for every process.
        # This also sets @INC.
        PerlPostConfigRequire /opt/otobo-vhost/scripts/apache2-perl-preload_otobo_psgi.pl

        # everything is handled by the PSGI app
        <Location />

        # handle all requests, including the static content, with otobo.psgi
        SetHandler perl-script
        PerlResponseHandler Plack::Handler::Apache2
        PerlSetVar psgi_app /opt/otobo-vhost/bin/psgi-bin/otobo.psgi

        # Require is supported starting with Apache 2.4.
        # No authentication and all requests are allowed.
        Require all granted

        </Location>
        </IfModule>

        </VirtualHost>

         

        Ich erkenne leider nicht wo der Fehler liegt damit ich das System mit der Domain otobo-vhost nicht erreiche.

    Viewing 0 reply threads
    • You must be logged in to reply to this topic.