Topic Resolution: Answered

Schlagwörter: 

Ansicht von 10 Antwort-Themen
  • Autor
    Beiträge
    • #11869
      Answered
      olivier-cimbaluria
      Teilnehmer

        Hello,

        I have a issue configuring the email collector which Exchange Online.

        I created an application in AzureAD which a redirectURL like https://fqdn/otobo/index.pl?Action=AdminMailAccount

        I configured the core/email/oauth2 system parameters with the secretID, domaine name, and applicationID but each time I create a new postmaster email, I’m redirected to the redirectURL (https://fqdn/otobo/index.pl?Action=AdminMailAccount) and I have this error in the system logs :

        Can’t perform POST on https://login.microsoftonline.com/common/oauth2/v2.0/token: 401 Unauthorized
        Could not request access token
        Got: ‘401 Unauthorized’!

        Thanks for your help.

      • #13060
        Franz Metzger
        Teilnehmer

          Hello Oliver,

          I have exactly the same problem here. Were you able to fix this without the help of the community?

          THX,

          Franz

        • #13414

          Hey there,

           

          I am facing similar issue.

          Any help?

           

          Thx,

          Michael

          • #13470
            Pascal Stierli
            Teilnehmer

              Just had the same issue. You need to create a “secret” within Azure for your App and add this secret within Otobo-Configuration. Afterwards I was able to auth via OAuth2 and fetch mails :)

               

              1. Create a secret in Azure (should be “Certificates and Secrets” in english
              2.  Copy the Value from the Column “Wert” (Value in english, 3rd Column from left) and enter it within otobo oauth profile configuration (and of course the client id if you didn’t provided it yet):

              Now try to configure mail fetch with OAuth2 again :) Hope this solves your Problem.

               

          • #13417
            Pawel Bosak
            Teilnehmer

              Hi, guys which api permission you set in azure app?

              They should be

              • Microsoft graph:
              • IMAP.AccessAsUser.All
              • offline_access
              • POP.AccessAsUser.All
              • User.Read

               

              Next You should grant admin consent for organization for all permission (do it in app registration and enterprise application on permission tab)

              • Diese Antwort wurde geändert vor 1 Jahr, 7 Monaten von Pawel Bosak.
            • #13418
              Private Reply
              Pawel Bosak
              Teilnehmer
                This reply has been marked as private.
              • #13469
                Pavel Lyachin
                Teilnehmer

                  Hi!

                  Faced with the problem that it is impossible to select a profile when creating a postmaster account.

                  Profile and provider configured, but I can’t select the right one. Profile value is not populated in mysql table. And apparently that’s why the Office 365 authorization window does not open.

                  Is this a bug? And how to win it?

                  Thx for answers!

                  PS: I’m using Google translate, because it’s not my native language.

                   

                   

                  • #13473
                    Private Reply
                    Pascal Stierli
                    Teilnehmer
                      This reply has been marked as private.
                    • #13479
                      zzz
                      Teilnehmer

                        Hello Pavel,

                        Interesting, it looks like your server is not using /opt/otobo/Custom/Modules*. This might be caused by Issue #1650.

                        Please check if your Apache config contains following line:
                        PerlSwitches -I /opt/otobo -I /opt/otobo/Kernel/cpan-lib -I /opt/otobo/Custom

                        If so,  replace it with this line:
                        PerlPostConfigRequire /opt/otobo/scripts/apache2-perl-preload_otobo_psgi.pl

                        Restart the web server and check if profiles appear.

                        Your feedback would be appreciated!

                        Best regards
                        Emin

                      • #13483
                        Pavel Lyachin
                        Teilnehmer

                          Thank you! You have been very helpful!

                          The problem was precisely this.

                           

                          I’m using OTOBO 10.1.4 based on Rocky Linux 8.6 without dockers.

                          Initially, a migration was made from the OTRS 6 Community Edition.

                          Maybe this information will be valuable in the analysis of the origin of this bug.

                           

                          Best regards

                          Pavel

                           

                          • Diese Antwort wurde geändert vor 1 Jahr, 7 Monaten von Pavel Lyachin.
                      • #13478
                        Pavel Lyachin
                        Teilnehmer

                          Unfortunately, I’m not a topic starter or a moderator, so I can’t read the post above.

                        • #13968
                          Best Answer
                          Stefan Rother
                          Administrator
                          • #14305
                            Domas Ubys
                            Teilnehmer

                              Hello,

                              I have an issue with the OAuth2 Authentication setup.

                              I have made all configurations as in show in the manual, but I don’t receive emails from the server.

                              I don’t receive new tickets :(

                              When I add under “Admin -> PostMaster Mail Account” connection credentials and then save the settings I’m redirected to  “Azure  Active Directory” login.

                              After entering the password, then I Accept Azure information and I’m redirected to the Otobo Dashboard.

                              I don’t receive any problems from wrong connections and et.c

                              But, when I check configuration under “Admin -> PostMaster Mail Account” – there is no set configuration.

                              Where can be a problem, and how I can solve it?

                              Best Regards,

                              Domas

                            • #14315
                              Domas Ubys
                              Teilnehmer

                                I found where was the issue in my case. Redirect URL  must be this = https://<OTOBO address>/otobo/index.pl?Action=AdminMailAccount

                              • #16045
                                Hristo Hristov
                                Teilnehmer

                                  Hello, I have the same issue, how did you fix it Domas, because I’m getting redirected to this URL

                                  https://<OTOBO address>/otobo/index.pl?Action=AdminMailAccount

                                  But still can’t find the configured Postmaster Mailaccount.

                              Ansicht von 10 Antwort-Themen
                              • Du musst angemeldet sein, um auf dieses Thema antworten zu können.