Ansicht von 4 Antwort-Themen
  • Autor
    Beiträge
    • #13167
      Frank Rauh
      Teilnehmer

      Hallo,

       

      nach Update laut Anleitung, auf die Version 10.1.3 bzw. 10.1.4, startet der NGINX nicht mehr,

      folgende Fehlermeldung gelb markiert:

       

      Als Authentifizierung wird jeweils kerberos verwendet, sprich folgende Files:

      –  /opt/otobo-docker/.docker_compose_env_https_kerberos –> .env
      – /opt/otobo-docker/otobo-base.yml
      – /opt/otobo-docker/otobo-override-https-kerberos.yml
      + keytab wird vom Host (über die otobo-override-https-kerberos.yml) gemountet /etc/krb5
      + krb5.conf generated krb5.conf.template /etc/krb5.conf im NGINX Container

      Ein Update von 10.1.1 auf 10.1.2 funktioniert noch ohne Probleme.

       

      Frage:

      Woran könnte es liegen?

      Sind Fehler in den Versionen 10.1.3 oder 10.1.4 schon bekannt?

      Für eine Rückmeldung wäre ich sehr dankbar.

       

      Viele Grüße

      Frank

       

       

    • #13168
      Stefan Rother
      Verwalter

      Hallo Frank,

      ja, wir haben hier einen Bug behoben: https://github.com/RotherOSS/otobo/commit/1a8f405b3750198ebd818e6ea35f33217ee60a0e

      Und eventuell haben wir hier einen neuen Bug generiert, wenn keine eigene NGINX Config verwendet wird, sorry.

      Ich würde jetzt eigene NGINX Config anlegen wie hier beschrieben:

      https://doc.otobo.org/manual/installation/10.1/en/content/installation-docker.html#custom-configuration-of-the-nginx-webproxy

      Bitte nicht vergessen in der .env folgendes zu ändern/setzen:

      COMPOSE_FILE=docker-compose/otobo-base.yml:docker-compose/otobo-override-https-kerberos.yml:docker-compose/otobo-nginx-custom-config.yml
      NGINX_ENVSUBST_TEMPLATE_DIR=/etc/nginx/config/template-custom

      Danach sollte der Pfad eigentlich stimmen und alles sollte wieder klappen. Weiterer Vorteil wäre das Du eine NGINX Config hast, die Du bearbeiten kannst. Alternative ist, Du wartest auf die 10.1.5 nächste Woche.

      Du kannst aber auch die Datei direkt verändern, wenn NGINX nicht startet (zum Beispiel um zu testen).

      Beispiel:

      root> docker cp otobo_nginx_1:/docker-entrypoint.d/21-envsubst-on-krb5-conf.sh .

      Danach kannst Du die Datei bearbeiten und den Pfad darin anpassen: /etc/nginx/templates/../kerberos/templates/krb5.conf.template

      Und die Datei wieder in den Container kopieren:

      root> docker cp 21-envsubst-on-krb5-conf.sh otobo_nginx_1:/docker-entrypoint.d/21-envsubst-on-krb5-conf.sh

      Nginx neu laden

      root> docker exec -it otobo_nginx_1 nginx -s reload

      Ich glaube für die 10.1.5 habe ich die Lösung bereits. Ich habe den Default Path angepasst, so dass bei der 10.1.5 alles wieder normal funktionieren sollte, auch wenn kein eigenes Configfile existiert.

      Ich hoffe ich konnte Dir helfen!

      Stefan Rother

      Team OTOBO

    • #13169
      Frank Rauh
      Teilnehmer

      Hallo Stefan,

       

      vielen Dank für die sehr schnelle Rückmeldung!

      Ich teste mal und melde mich…

       

      Viele Grüße

      Frank

    • #13172
      Frank Rauh
      Teilnehmer

      uj

    • #13173
      Frank Rauh
      Teilnehmer

      Guten Morgen,

      eine eigene NGINX Config habe ich nicht erstellt. Anpassen der Datei 21-envsubst-on-krb5-conf.sh funktioniert wie oben beschrieben. Aus Container kopieren, anpassen und wieder in den Container kopieren. Im Anschluss startet OTOBO 10.1.4. Den Default Fix in Version 10.1.5, warte ich ab.

      Danke! & Viele Grüße

      Frank

       

Ansicht von 4 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.