Topic Resolution: Resolved

Schlagwörter: 

Ansicht von 2 Antwort-Themen
  • Autor
    Beiträge
    • #13008
      Leon Baier
      Teilnehmer

      Hallo allerseits,

      nach dem Update von 10.0.10 auf 10.1.2 wird man auf /otobo weitergeleitet anstatt wie vorher auf /otobo/index.pl, was zu einem 404 Fehler fuehrt.

      Das DefaultInterface ist bei mir index.pl

      ~$ bin/otobo.Console.pl Admin::Config::Read –setting-name Frontend::DefaultInterface
      Gathering setting value…

      Setting: Frontend::DefaultInterface
      index.pl

      Ich koennte jetzt zwar die /opt/otobo/var/httpd/htdocs/index.html anpassen, die dann aber bei jedem Update wieder ueberschrieben wird.

      Am liebsten waere mir, wenn ich Otobo ueber https://subdomain.domain.tld/ aufrufen koennte, ohne „/otobo“. Ich nutze Apache2 auf Ubuntu 20.04.

       

    • #13011
      bes
      Teilnehmer

      Hallo Leon,

      ja, die Routen sind in OTOBO nicht optimal. Dazu gibt es auch ein Discussion auf Github. Die Abwägung zwischen Einfachheit und Flexibilität ist ja nie ganz einfach.

      Das Verhalten auf deiner Installation erscheint mir jedenfalls fehlerhaft. Zuerst einmal wie es per Design ablaufen sollte:

      1. https://example.com wird im Browser aufgerufen
      2. Der Server liefert das Standard index.html aus , also Redirect auf /otobo
      3. Browser folgt Redirect und ruft https://example.com/otobo
      4. Der Server liefert das Standardinterface aus, also das Kundeninterface index.pl

      Der Schritt 4 scheint bei dir fehlerhaft zu sein.  Es sollte kein Status 404 kommen. Ich habe die Vermutung dass die Apache Config nicht angepasst wurde. Die empfohlene Konfiguration ist https://github.com/RotherOSS/otobo/blob/rel-10_1/scripts/apache2-httpd.include.conf . Entscheidend sind die folgenden Zeilen:

      PerlResponseHandler Plack::Handler::Apache2
      PerlSetVar psgi_app /opt/otobo/bin/psgi-bin/otobo.psgi

      Das erlaubt OTOBO die Logik für das Default-Interface zu implementieren.

      Die Seiten index.html und 404.html können für die jeweilige Installation angepasst werden. Es stimmt aber dass die Anpassungen per Default bei einem Update überschrieben werden. Deswegen empfehlen wir alle Anpassungen in ein OTOBO-Paket zu packen. Die OTOBO-Pakete werden dann bei einem Upgrade entweder automatisch oder manuell neu installiert.

      Viele Grüße,

      Bernhard

       

       

       

       

       

    • #13026
      Leon Baier
      Teilnehmer

      Die apache2-httpd.include.conf sieht bei mir genau so aus. Beim Vergleich der anderen Dateien habe ich festgestellt, dass sich die apache2-httpd-vhost-443.include.conf beim Update sehr geaendert hat. Nachdem ich sie in mein Apache-Config-Verzeichnis kopiert und entsprechend  angepasst habe, funktioniert jetzt alles.

      Vielleicht sollte ein Hinweis darauf in die Update-Dokumentation aufgenommen werden.

Ansicht von 2 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.