Topic Resolution: Resolved
Ansicht von 5 Antwort-Themen
  • Autor
    Beiträge
    • #12125
      Philipp Reimann
      Teilnehmer

        Hallo liebe Community,

        ich versuche gerade verzweifelt die „Kundenummer (exakte Suche)“ als Filter in das Standard Suchfeld einzubinden.
        Leider habe ich nur die Möglichkeit die „Kundennummer (komplexe Suche)“ dort einzubinden.

        Ich habe bereits versucht dies in „Ticket::Frontend::AgentTicketSearch###DynamicField“ manuell einzutragen, leider ohne Erfolg.

        Wenn ich „Ticket::Frontend::AgentTicketSearch###Defaults###CustomerID“ aktiviere erhalte ich „nur“ die „Kundenummer (komplexe Suche“ im Standard-Suchfeld.

        Hat jemand eine Idee was ich falsch mache?
        Bin für jeden Tipp dankbar!

        Danke im voraus :)

        Liebe Grüße
        Phil

      • #12126
        Renée Bäcker
        Teilnehmer

          Packe das hier in eine Datei unter /opt/otobo/Kernel/Config/Files/XML:

          <?xml version="1.0" encoding="utf-8"?>
          <otrs_config version="2.0" init="Config">
              <Setting Name="Ticket::Frontend::AgentTicketSearch###Defaults###CustomerIDRaw" UserPreferencesGroup="Advanced" UserModificationActive="1" UserModificationPossible="1" Required="0" Valid="1">
                  <Description Translatable="1">Defines the default shown ticket search attribute for ticket search screen.</Description>
                  <Navigation>Frontend::Agent::View::TicketSearch</Navigation>
                  <Value>
                      <Item ValueType="String"></Item>
                  </Value>
              </Setting>
          </otrs_config>

          Anschließend noch perl bin/otobo.Config.pl Maint::Config::Rebuild ausführen

        • #12127
          Renée Bäcker
          Teilnehmer

            Also in eine neue Datei, nicht in eine bestehende…

          • #12130
            Philipp Reimann
            Teilnehmer

              Hallo Renée,

              Vielen Dank für deine schnelle Antwort!

              Leider kann ich die „otobo.Config.pl“ auf meinem System nicht finden.
              Auch wenn ich eine frische Otobo Installation herunterlade und entpacke, kann ich diese Datei nicht finden. :(
              Hast du einen weiteren Tipp für mich?

              Zum System:
              Ich nutze Otobo 10.0.13 welches recht frisch (2 Wochen alt) installiert ist.
              Die installation ist nicht in Docker realisiert und wurde auf einem Ubuntu 20.04 LTS installiert. Ich habe mich da streng an die Anleitung gehalten.

              Im Nachgang wurden Daten aus einer OTRS Installation übernommen.

              Liebe Grüße

              Phil

            • #12142
              Renée Bäcker
              Teilnehmer

                Ich meinte „otobo.Console.pl“ Sorry

              • #12165
                Philipp Reimann
                Teilnehmer

                  Hallo René,

                  danke für deine Hilfe, das hätte ich in 100 Jahren nicht hinbekommen ;)

                  Allerdings gibt es noch eine kleine korrektur in der XML-Date die ich vornehmen musste.
                  Und zwar musste in meinem Fall dort „<otobo_config …“ stehen.
                  Im Original Post stand dort „<otrs_config….“

                  Falls mal jemand das gleiche Problem hat hier nochmal alles zusammengefasst:

                  1. Diesen Code in einer separaten XML Datei unter „/opt/otobo/Kernel/Config/Files/XML“ Speichern.

                  <?xml version="1.0" encoding="utf-8"?>
                  <otobo_config version="2.0" init="Config">
                      <Setting
                  Name="Ticket::Frontend::AgentTicketSearch###Defaults###CustomerIDRaw"
                  UserPreferencesGroup="Advanced" UserModificationActive="1"
                  UserModificationPossible="1" Required="0" Valid="1">
                          <Description Translatable="1">Defines the default
                  shown ticket search attribute for ticket search
                  screen.</Description>
                          <Navigation>Frontend::Agent::View::TicketSearch</Navigation>
                          <Value>
                              <Item ValueType="String"></Item>
                          </Value>
                      </Setting>
                  </otrs_config>

                  2. su - otobo  (in den otobo User wechseln im normalfall „otobo“)
                  3. perl bin/otobo.Console.pl Maint::Config::Rebuild  ausführen.
                  4. Bei Renée bedanken.

                  Vielen Dank nochmal!

                  LG

                  Phil

                  • Diese Antwort wurde geändert vor 1 Jahr, 2 Monaten von Philipp Reimann.
              Ansicht von 5 Antwort-Themen
              • Du musst angemeldet sein, um auf dieses Thema antworten zu können.