Topic Resolution: Answered
Ansicht von 1 Antwort-Thema
  • Autor
    Beiträge
    • #12545
      Answered
      Robin
      Teilnehmer

      Hallo zusammen,
      ich habe ein Problem beim einbinden einer LDAPs Verbindung für die Kundendatenbank.
      Meiner erste LDAP Verbindung ohne LDAPs funktioniert ohne Probleme. Jetzt habe ich die Config für die LDAPs Verbindung wie folgend angepasst:

       Params => {
      verify => 'none',
      port => 636,
      timeout => 120,
      async => 0,
      version => 3,
      cafile => '/opt/otobo/Custom/cacerts/***.cer'
      },

      Soweit so gut, leider bekomme ich folgende Fehlermeldung:

      Message: Search failed! Can't contact LDAP server

      Woran kann es liegen, bzw. was habe ich falsch gemacht?

      Danke im Voraus!

      Gruß Robin

       

      System: OTOBO latest stable release (docker)

    • #12549
      Best Answer
      Robin
      Teilnehmer

      Hallo zusammen,

      ich habe das Problem bereits selbst gelöst.

      `Name => ‚LDAP Backend‘,
      Module => ‚Kernel::System::CustomerUser::LDAP‘,
      Params => {
      Host => ‚ldaps://ldaps.host.**‘,
      BaseDN => ‚dc=**,dc=**‘,
      SSCOPE => ’sub‘,
      UserDN => ‚**‘,
      UserPw => ‚**‘,
      AlwaysFilter => “,
      Die => 0,
      Params => {
      verify => ’none‘,
      port => 636,
      timeout => 120,
      async => 0,
      version => 3,
      },
      },
      `

      Mit dieser Config, klappt es. Wichtig ist das ldaps:// vor dem LDAP-Host.
      Gruß Robin

Ansicht von 1 Antwort-Thema
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.