Topic Resolution: Answered
Ansicht von 2 Antwort-Themen
  • Autor
    Beiträge
    • #11305
      Answered
      Kyle F
      Teilnehmer

      Hi all, I’m working on migrating an existing OTRS 6.0.30 install to Oboto to get a sense of what’s required. I’m getting all the way through the migration.pl pages and steps, but getting an error when securemode is trying to be re-activated. Error below.

       

      Backend ERROR: OTOBO-CGI-61 Perl: 5.30.0 OS: linux Time: Tue Apr 6 19:12:36 2021

      Message: Can’t activate SecureMode: Setting SecureMode is not locked to this user!

      RemoteAddress: 172.16.42.22
      RequestURI: /otobo/migration.pl

      Traceback (657):
      Module: Kernel::Modules::MigrateFromOTRS::_Finish Line: 573
      Module: Kernel::Modules::MigrateFromOTRS::Run Line: 498
      Module: Kernel::System::Web::InterfaceMigrateFromOTRS::Run Line: 149
      Module: ModPerl::ROOT::ModPerl::Registry::opt_otobo_bin_cgi_2dbin_migration_2epl::handler Line: 38
      Module: (eval) (v1.99) Line: 207
      Module: ModPerl::RegistryCooker::run (v1.99) Line: 207
      Module: ModPerl::RegistryCooker::default_handler (v1.99) Line: 173
      Module: ModPerl::Registry::handler (v1.99) Line: 32

       

      I’ll try to login with a migrated user and/or the root@localhost user and they all fail. Any help? Thanks!

    • #11321
      Kyle F
      Teilnehmer

      Here’s some more info I pulled out of the logs(journalctl).

       

      [Error][Kernel::System::MigrateFromOTRS::OTOBOOTRSConnectionCheck::Run][Line:136]: Can’t open Kernel/Config.pm file from OTRSHome: /opt/otrs!
      [Error][Kernel::System::MigrateFromOTRS::CloneDB::Driver::Base::SanityChecks][Line:182]: Access denied for user ‚otrsdb’@’localhost‘ (using password: YES)
      [Error][Kernel::System::MigrateFromOTRS::CloneDB::Driver::Base::SanityChecks][Line:185]: Try database connect and sanity checks. Could not connect to the source database!
      [Error][Kernel::System::MigrateFromOTRS::CloneDB::Driver::Base::SanityChecks][Line:182]: Unknown database ‚otrs‘
      [Error][Kernel::System::MigrateFromOTRS::CloneDB::Driver::Base::SanityChecks][Line:185]: Try database connect and sanity checks. Could not connect to the source database!
      [Error][Kernel::System::MigrateFromOTRS::Base::MigrationLog][Line:1172]: Could not replace license header of /opt/otobo/Kernel/Config.pm.
      [Error][Kernel::System::Main::FileWrite][Line:515]: Can’t write ‚/opt/otobo/var/cron/otobo_daemon‘: Permission denied
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:462]: Setting AdminEmail does not exist!
      [Error][Kernel::System::SysConfig::ConfigurationLoad][Line:4280]: Setting AdminEmail (global) was not correctly updated!
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:462]: Setting FQDN does not exist!
      [Error][Kernel::System::SysConfig::ConfigurationLoad][Line:4280]: Setting FQDN (global) was not correctly updated!
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:462]: Setting Organization does not exist!
      [Error][Kernel::System::SysConfig::ConfigurationLoad][Line:4280]: Setting Organization (global) was not correctly updated!
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:462]: Setting SecureMode does not exist!
      [Error][Kernel::System::SysConfig::ConfigurationLoad][Line:4280]: Setting SecureMode (global) was not correctly updated!
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:462]: Setting SystemID does not exist!
      [Error][Kernel::System::SysConfig::ConfigurationLoad][Line:4280]: Setting SystemID (global) was not correctly updated!
      [Error][Kernel::System::SysConfig::SettingGet][Line:201]: Setting SecureMode is invalid!
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:462]: Setting SecureMode does not exist!
      [Error][Kernel::System::SysConfig::DB::DeploymentAdd][Line:4440]: EffectiveValueStrg is invalid!
      [Error][Kernel::System::SysConfig::ConfigurationDeploy][Line:3600]: Could not create the deployment in the DB!
      [Error][Kernel::System::SysConfig::DB::DefaultSettingLock][Line:1689]: Cannot add or update a child row: a foreign key constraint fails (otobo.sysconfig_default, CONSTRAINT FK_sysconfig_default_exclusive_lock_user_id_id FOREIGN KEY (exclusive_lock_user_id) REFERENCES users (id)), SQL: ‚
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:442]: Need TargetUserID or ExclusiveLockGUID!
      [Error][Kernel::System::SysConfig::DB::DefaultSettingIsLockedByUser][Line:1864]: Need ExclusiveLockGUID!
      [Error][Kernel::System::SysConfig::SettingUpdate][Line:488]: Setting SecureMode is not locked to this user!
      [Error][Kernel::Modules::MigrateFromOTRS::_Finish][Line:573]: Can’t activate SecureMode: Setting SecureMode is not locked to this user!

    • #11339
      Best Answer
      Kyle F
      Teilnehmer

      I did end up figuring this out:

      1. Copied OTRS mysql database and imported into mysql install on Otobo server
      2. Copied /opt/otrs directory over to Otobo install and set otobo:www-data permissions
      3. Ran through the migration.pl pages again with local options.
Ansicht von 2 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.