Topic Resolution: Answered

Schlagwörter: 

Ansicht von 2 Antwort-Themen
  • Autor
    Beiträge
    • #13290
      Answered
      Sven Jansen
      Teilnehmer

        Hallo zusammen,

        ich habe heute eine Docker Installation von OTOBO 10.1.4 durchgeführt und versuche mich gerade daran die Postmaster Mailkonten einzurichten. Da Microsoft im Oktober das „basic auth“ einstellt, versuche ich das Postfach als POP3Outh einzurichten.

        Ich habe eine App Registration erstellt und als Redirect URL „https://otobofqdn/otobo/index.pl?Action=AdminMailAccount eingetragen. Ich habe die Client ID und ein Secret erstellt.

        In der Systemkonfiguration habe ich das im schon vorhandenen Azure Profil „OAuth2::MailAccount::Providers###MicrosoftAzure“ angepasst, da OAUTH nur noch mit der Tenant Spezifischen URL in Form von https://login.microsoftonline.com/meinetenantid/oauth2/v2.0/token möglich ist, ohne die Änderung kam eine Rückmeldung mit dem Hinweis die Tenant URL zu verwenden.

        Ich habe ein „OAuth2::MailAccount::Profiles###Custom1“ erstellt und dort die ClientID und das Secret eingetragen, Providername ist der oben genannte „MicrosoftAzure“. Im Anschluss habe ich ein E-Mail Konto des Typs POP3OAuth erstellt und dort das erstellt OAUTH Profil ausgewählt und als Username die Mailadresse des Postfachs eingetragen. Wenn ich den Dialog bestätige dann werde ich auf die Microsoft Seite geleitet und erhalte sofort ein „AADSTS900561: The endpoint only accepts POST, OPTIONS requests. Received a GET request.“.

        Hat einer eine Idee was hier schiefläuft?

         

        • Dieses Thema wurde geändert vor 6 Monaten, 1 Woche von Sven Jansen.
      • #13298
        Best Answer
        zzz
        Teilnehmer

          Hallo Sven,

          wenn Du mit einer spezifischen Tenant arbeiten möchtest, musst Du nicht nur die URL in TokenURL anpassen, sondern auch in AuthURL.

          Ein Beispiel für OAuth2::MailAccount::Providers###MicrosoftAzure:

          AuthURL
          von https://login.microsoftonline.com/common/oauth2/v2.0/authorize
          zu https://login.microsoftonline.com/c5ff1sds-4cc5-4144-a1g8-c93c63be2842/oauth2/v2.0/authorize

          TokenURL
          von https://login.microsoftonline.com/common/oauth2/v2.0/token
          zu https://login.microsoftonline.com/c5ff1sds-4cc5-4144-a1g8-c93c63be2842/oauth2/v2.0/token

          Sag Bescheid, wenn es noch Proleme geben sollte.

          Viele Grüße
          Emin

        • #13300
          Sven Jansen
          Teilnehmer

            Hallo Emin,

            kaum macht man es richtig und dann funktioniert das auch. Ich habe optisch gar nicht wahrgenommen das es einmal authorize und einmal token ist. Ich habe hier tatsächlich oben und unten die Token URL reingesetzt obwohl ja davor steht was da rein gehört /o\

            Jetzt funktioniert das auch.

            Vielen Dank Emin!

            Gruß

            Sven

             

        Ansicht von 2 Antwort-Themen
        • Du musst angemeldet sein, um auf dieses Thema antworten zu können.