Schlagwörter: 

Ansicht von 3 Antwort-Themen
  • Autor
    Beiträge
    • #12668
      Yannic Rubenzer
      Teilnehmer

      Hallo,

      ich habe ein folgendes Probelm mit dem Restor eines Backups auf einem neuen Server.

      Auf dem neuen Server habe ich folgende Schritte gemacht :

      • mkdir otobo_backup
      • chown 1000:1000 otobo_backup
      • docker volume create –name otobo_backup –opt type=none –opt device=$PWD/otobo_backup –opt o=bind
      • docker volume inspect otobo_backup

      Backup vom alten Server per rsync auf den neuen frisch mit OTOBO intsallieren Server ins Verzeichniss /otobo_backup/2022-02-12_00-08-33 kopiert

      Beim ausführen des Befehls

      • docker run -it –rm –volume otobo_opt_otobo:/opt/otobo –volume otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest-10_0 scripts/restore.pl -d /opt/otobo -b /otobo_backup/2022-02-12_00-08-33

      erscheint folgende Fehlermeldung

      • ERROR: No such directory: /otobo_backup/2022-02-12_00-08-33

       

      Zum Test habe ich versucht auf dem neuen Server ein Backup zu erstellen

      • docker run -it –rm –volume otobo_opt_otobo:/opt/otobo –volume otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest-10_0 scripts/backup.pl -d /otobo_backup

      Auch hier erscheint folgender Fehler

      • backup.pl: ERROR: Can’t create directory: /otobo_backup/2022-02-12_16-03-31: Permission denied at /opt/otobo/scripts/backup.pl line 239.

      Auf dem neuen Server ist folgende Docker Version installiert

      Docker version 20.10.5+dfsg1, build 55c4c88

      docker-compose version 1.25.0, build unknown

       

       

       

       

    • #12670
      bes
      Teilnehmer

      Hallo Yannic,

      anscheinend ist das ja ein Rechteproblem. Auffallend an den ausgeführten Befehlen ist nur das chown 1000:1000 otobo_backup. Auf den ersten Blick kann ich aber nicht sagen welche Auswirkungen das im laufenden Container hat. Es wäre also interessant zu wissen welche Rechte effektiv gesetzt sind. Kannst du die Rechte prüfen? In meiner Testinstallation sieht es folgendermaßen aus:

      bes:~/devel/OTOBO/otobo-docker (rel-10_1)$ docker run -it --rm --volume otobo_opt_otobo:/opt/otobo --volume otobo_backup:/otobo_backup --network otobo_default rotheross/otobo:latest-10_0 bash
      otobo@cee252e28018:~$ ls -ld /otobo_backup/
      drwxrwxr-x 3 otobo otobo 4096 Feb 14 10:02 /otobo_backup/
      otobo@cee252e28018:~$

       

      Viele Grüße,

      Bernhard

       

    • #12675
      Yannic Rubenzer
      Teilnehmer

      Hallo Bernhard,

      ich habe deinen Befehl getestet

      • docker run -it –rm –volume otobo_opt_otobo:/opt/otobo –volume otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest-10_0 bash
      • ls -la
      • drwxrwxrwx 3 otobo otobo 4096 Feb 14 10:54 otobo_backup

      In diesem Ordner befindet sich das Verzeichnis 2022-02-12_00-08-33 mit folgenden Berechtigungen

      • drwxrwxrwx 2 root root 4096 Feb 14 10:54 2022-02-12_00-08-33

      Die Ordner auf dem Hostsystem haben ebenfalls diese Berechtigungen

      • drwxrwxrwx 3 debian debian 4096 Feb 12 16:15 otobo_backup
      • drwxrwxrwx 2 debian debian 4096 Feb 12 16:15 2022-02-12_00-08-33

      Der Befehl

      • docker run -it –rm –volume otobo_opt_otobo:/opt/otobo –volume otobo_backup:/otobo_backup –network otobo_default rotheross/otobo:latest-10_0 scripts/restore.pl -d /opt/otobo -b /otobo_backup/2022-02-12_00-08-33

      Führ immer noch zur folgenden Ausgabe

      • ERROR: No such directory: /root/otobo_backup/2022-02-12_00-08-33

       

    • #12680
      bes
      Teilnehmer

      Hallo Yannic,

      die Verzeichnisse sehen wie erwartet aus. Ein Punkt verwirrt mich aber. Im Befehl wird die Option  -b /otobo_backup/2022-02-12_00-08-33 übergeben. Aber die Meldung ist dass /root/otobo_backup/2022-02-12_00-08-33 nicht existiert. Kann es sein dass sich im Aufruf ein /root eingeschlichen hat?

      Viele Grüße,

      Bernhard Schmalhofer

       

Ansicht von 3 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.