Schlagwörter: 

Ansicht von 0 Antwort-Themen
  • Autor
    Beiträge
    • #11336
      pritish pattanaik
      Teilnehmer

      Dear All,

      First of all thank you very much OTOBO team for providing free ITSM ticketing tool with new improved self-service UI and technology stack (ES, Redis and Docker). I’ve been using OTRS CE for last couple of years, we are now planning to start with OTOBO as fresh(no ticket data migration). I’ve installed OTOBO IOT servers ( RHEL 7) from source, it was bit challenging to complete the setup but indeed it worked. I’ll share the OTOBO installation steps for RHEL 7 from source.

      I am having challenges to configure mod_perl for OTOBO. My dev instance is up and running but without mod_perl. Please someone help on this matter if you have configured or knowledge on how to run mod_perl with OTOBO

      # check if mod_perl is running or not

      telnet localhost 80
      Trying ::1...
      Connected to localhost.
      Escape character is '^]'.
      HEAD HTTP/1.0
      HTTP/1.1 400 Bad Request
      Date: Mon, 12 Apr 2021 07:10:23 GMT
      Server: Apache/2.4.6 (Red Hat Enterprise Linux)
      Connection: close
      Content-Type: text/html; charset=iso-8859-1

      I’ve installed mod_perl packaged provided by RHEL, I use Perl 5.26 which is not default in RHEL. RHEL ships Perl version 5.16 as default

      $ yum install rh-perl526-mod_perl-devel.x86_64

      It is successful installed but i don’t see any 02-perl.conf file inside /etc/httpd/conf.modules folder. When i set up OTRS 6(Perl 5.16) on one of my RHEL 7 server with yum intstall mod_perl everything was working smoothly but in this case i suspect due to Perl version it creates conflict.

      FYI – If i install mod_perl using yum
      $yum install mod_perl

      it auto resolves dependency and install default Perl version 5.16 in server which creates conflict.

      Somewhere i need enable or Load mod_perl.so, i tried in httpd.conf and also created 02-perl.conf but none of them worked (apache didn’t start)

      OTOBO Version: 10.0.9
      OS: RHEL 7
      Apache: 2.4
      Perl: 5.26.3
      Perl path: /opt/rh/rh-perl526/root/usr/bin/perl

      Note – I need to configure below settings to run OTOBO on RHEL 7 with Perl 5.26

      # set this in your conf/httpd.conf file and restart apache if you encounter below error
      Error while loading shared libraries: libperl.so.rh-perl526-5.26: cannot open shared object file: No such file or directory

      $SetEnv LD_LIBRARY_PATH /opt/rh/rh-perl526/root/usr/lib64

      # In RHEL 7, you need to replace perl interpreter with /opt/rh/rh-perl526/root/usr/bin/perl in your index.pl, customer.pl and other scripts

      # installer.pl/index.pl/customer.pl and other script where perl interpreter
      #!/opt/rh/rh-perl526/root/usr/bin/perl

      Thank you in Advance, Hope to hear you from soon

      • Dieses Thema wurde geändert vor 5 Monaten, 1 Woche von pritish pattanaik. Grund: typo
Ansicht von 0 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.