Ansicht von 3 Antwort-Themen
  • Autor
    Beiträge
    • #11480

      Hello!

      Got a question about OTOBO translations (10.0.10 migrated from OTRS 6.0.30)

      I have registered on translate.otobo.org, downloaded polish translation file („Download original translation file (gettex PO file)“). Made some translations and fixed some typos in current ones and uploade it to review.

      Main questions is how to rebuild translations on already installed instance of OTOBO? I was following this developer manual – translations and nothing changed – I cannot see, my translations

      1. I’ve replaced file i18n/otobo/otobo.pl.pl with my new translations.
      2. I’ve run bin/otobo.Console.pl Dev::Tools::TranslationsUpdate  command from otobo user
      3. There was no errors during execution
      4. I’ve cleared cached data bin/otobo.Console.pl Maint::Cache::Delete
      5. Just in case Apache was restarted

      And nothing happed. I’ve tried to rebuild assets but script /opt/otobo/bin/otobo.WebServer.pl does not exists. Where I made a mistake/what I missed?

       

      Thank you for you help.

      Regards
      Przemek

    • #11481
      Grit Rother
      Verwalter

      Hi Przemek,

      I don’t know about the specific processes described in the developer manual, I’m afraid.

      However, I hope I can contribute a little bit nevertheless towards solving your problem:

      1. In Weblate, great part of the Polish project is marked as „needing action“ now, which probably isn’t really how this process is supposed to work. However, I’ll ask our Polish partners to have a look at the translations and validate your changes.
      2. As soon as your suggestions have been validated, they should be fed back to GitHub automatically the following night. Maybe this provides you with an option of getting your translations into your system?
      3. At the longer run, they will be available in OTOBO 10.0.11 as well.

      Maybe someone else can help with the specifics of changing language files directly in OTOBO.

      All the best,
      Grit

    • #11482

      In Weblate, great part of the Polish project is marked as „needing action“ now, which probably isn’t really how this process is supposed to work.

      That was my first time when I was using weblate. Probably misunderstand weblate documentation and marked wrong parameters while uploading translations.

       

      However, I’ll ask our Polish partners to have a look at the translations and validate your changes.
      As soon as your suggestions have been validated, they should be fed back to GitHub automatically the following night.

      Thank You!

       

      Regards
      Przemek

    • #11483

      Seems that translations works fine! I forgot that I have made some changes in pl.pm and placed it Custom/Kernel/Language/pl.pm. After deleting this file all translations made in i18n/otobo/otobo.pl.po works like a charm! Too many changes at once and I have lost ;)

      So case can be closed. Just waiting for info how to properly upload further translations.

       

      Regards
      Przemek

Ansicht von 3 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.