Ansicht von 10 Antwort-Themen
  • Autor
    Beiträge
    • #11282
      Eldaras Sad
      Teilnehmer

      Hello,

      I first run http://192.168.1.96/otobo/installer.pl

      I get an error 500 Internal Server Error

      Check log file /var/log/httpd/error_log

      I view two errors:

      Use of uninitialized value in concatenation (.) or string at /opt/otobo/Kernel/Output/HTML/Layout.pm line 1602.

      Message: mkdir /opt/otobo/var/tmp/CacheFileStorable/TemplateProvider: Permission denied at /opt/otobo/Kernel/System/Cache/FileStorable.pm line 99.

      FileStorable.pm permission is chmod 777

      I don’t understand what file permission should be?

       

    • #11283
      Jeffrey nvt
      Teilnehmer

      Message: mkdir /opt/otobo/var/tmp/CacheFileStorable/TemplateProvider: Permission denied at /opt/otobo/Kernel/System/Cache/FileStorable.pm line 99.

      The problem is „/opt/otobo/var/tmp/CacheFileStorable/TemplateProvider“. Make sure you set the correct user/group on /opt/otobo and all subdirectories/files.

      In case you’re using Debian/Ubuntu with Apache2, the correct user/group is chown -R otobo:www-data /opt/otobo

      FileStorable.pm permission is chmod 777

      Chmod 777 is not recommended, never trust everybody ;)

    • #11285
      Eldaras Sad
      Teilnehmer

      I installed OTOBO on CentOS 8

      My actions:

      root>useradd -r -U -d /opt/otobo -c ‚OTOBO user‘ otobo -s /bin/bash
      root>usermod -G apache otobo
      root>cp /opt/otobo/scripts/apache2-httpd.include.conf /etc/httpd/conf.d/zzz_otobo.conf
      root>chown -R otobo:apache /opt/otobo

      root>/opt/otobo/bin/otobo.SetPermissions.pl
      Skipping /.github (maybe here problem?)

      root>systemctl start httpd.service

      The problem remains:

      Can’t create directory ‚/opt/otobo/var/tmp‘:
      Can’t create directory ‚/opt/otobo/var/tmp/CacheFileStorable‘: No such file or directory
      mkdir /opt/otobo/var/tmp: Permission denied at /opt/otobo/Kernel/System/Cache/FileStorable.pm line 99.

      CheckModules.pl all OK.

      I uninstalled otobo and reinstalled it, but I still get the same error.

       

    • #11286
      Renée Bäcker
      Teilnehmer

      Is SELinux active?

    • #11290
      Eldaras Sad
      Teilnehmer

      SELinux status: enabled
      SELinuxfs mount: /sys/fs/selinux
      SELinux root directory: /etc/selinux
      Loaded policy name: targeted
      Current mode: enforcing
      Mode from config file: enforcing
      Policy MLS status: enabled
      Policy deny_unknown status: allowed
      Memory protection checking: actual (secure)
      Max kernel policy version: 33

      I installed:
      CentOS 8
      Otobo 10.0.9
      perl
      epel-release
      /opt/otobo/bin/otobo.CheckModules.pl -all program installed
      MySQL
      mysqltuner
      java-1.8.0-openjdk-devel
      elasticsearch

      Out of despair, I installed everything to new, but I still get the same error.

       

    • #11292
      hilocz
      Teilnehmer

      Have you tried Otobo in Docker ? Works fine, hassle free.

    • #11293
      Eldaras Sad
      Teilnehmer

      I will try to install OTOBO with the Docker. I hope everything works out.

    • #11304
      Eldaras Sad
      Teilnehmer

      Finally succeeded :-) ,
      after installing Docker launched the link: http://myip/otobo/installer.pl
      Many thanks to everyone for the help.

    • #11316
      Eldaras Sad
      Teilnehmer

      intsaller.pl
      I have problem in  step (2/4)

      User: root
      Password: MySQLrootpassword
      Host: db

      Can’t connect to MySQL server on ‚db‘ (115)

      systemctl status mysqld.service (active)
      I checked mysql -u root -p. It’s ok.

       

    • #11340
      Eldaras Sad
      Teilnehmer

      systemctl stop firewalld.service
      http://myserverip/otobo/installer.pl (2/4)
      Database check successful.

      systemctl start firewalld.service
      Can’t connect to MySQL server on ‚db‘ (115)

      firewall-cmd –zone=public –add-service=mysql –permanent
      firewall-cmd –zone=public –add-port=3306/tcp –permanent
      firewall-cmd –zone=public –add-source=myip
      firewall-cmd –reload

      my.cnf
      #bind-address=0.0.0.0

      I still get a mysql error 115

      Maybe someone knows how to configure the firewall correctly to connect to mysql?

    • #11416
      Eldaras Sad
      Teilnehmer

      I talked to myself :-)
      Solution found:
      firewall-cmd –zone = public –add-masquerade –permanent

Ansicht von 10 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.