Schlagwörter: 

Ansicht von 1 Antwort-Thema
  • Autor
    Beiträge
    • #13509
      Marek Soth
      Teilnehmer

        Hello,

        I have followed this guide to install new skin:

        https://doc.otobo.org/manual/developer/10.1/en/content/how-it-works/skins.html#creating-a-new-skin

        I followed it exactly and for the beggining only logo and background change as written in the guide.

        The new skin “custom” appears and works.

        One thing I had to do differently, the XML file in the docs is probably an old version?

        I had to use another which I have found on these forums:

        https://prnt.sc/wqvm1-p_xLNv

        However when running the:

        sudo su -c "bin/otobo.Console.pl Maint::Config::Rebuild" -s /bin/bash otobo

        command, I get several YAML errors:

        root@otobo:/opt/otobo# sudo su -c "bin/otobo.Console.pl Maint::Config::Rebuild" -s /bin/bash otobo
        Rebuilding the system configuration...
        ERROR: OTOBO-otobo.Console.pl-Maint::Config::Rebuild-59 Perl: 5.30.0 OS: linux Time: Mon Aug 1 12:18:00 2022

        Message: Loading the YAML string failed:

        Traceback (97058):
        Module: Kernel::System::YAML::Load Line: 125
        Module: Kernel::System::SysConfig::DB::DefaultSettingListGet Line: 1398
        Module: Kernel::System::SysConfig::_GetSettingsToDeploy Line: 5899
        Module: Kernel::System::SysConfig::ConfigurationDeploy Line: 3442
        Module: Kernel::System::Console::Command::Maint::Config::Rebuild::Run Line: 153
        Module: (eval) Line: 480
        Module: Kernel::System::Console::BaseCommand::Execute Line: 474
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        ERROR: OTOBO-otobo.Console.pl-Maint::Config::Rebuild-59 Perl: 5.30.0 OS: linux Time: Mon Aug 1 12:18:00 2022

        Message: YAML data was: "--- |2

        Dear Customer,

        Unfortunately we could not detect a valid ticket number
        in your subject, so this email can't be processed.

        Please create a new ticket via the customer panel.

        Thanks for your help!

        Your Helpdesk Team
        "

        Traceback (97058):
        Module: Kernel::System::YAML::Load Line: 133
        Module: Kernel::System::SysConfig::DB::DefaultSettingListGet Line: 1398
        Module: Kernel::System::SysConfig::_GetSettingsToDeploy Line: 5899
        Module: Kernel::System::SysConfig::ConfigurationDeploy Line: 3442
        Module: Kernel::System::Console::Command::Maint::Config::Rebuild::Run Line: 153
        Module: (eval) Line: 480
        Module: Kernel::System::Console::BaseCommand::Execute Line: 474
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        ERROR: OTOBO-otobo.Console.pl-Maint::Config::Rebuild-59 Perl: 5.30.0 OS: linux Time: Mon Aug 1 12:18:00 2022

        Message: YAML data was not readable even by pure-perl YAML module

        Traceback (97058):
        Module: Kernel::System::YAML::Load Line: 144
        Module: Kernel::System::SysConfig::DB::DefaultSettingListGet Line: 1398
        Module: Kernel::System::SysConfig::_GetSettingsToDeploy Line: 5899
        Module: Kernel::System::SysConfig::ConfigurationDeploy Line: 3442
        Module: Kernel::System::Console::Command::Maint::Config::Rebuild::Run Line: 153
        Module: (eval) Line: 480
        Module: Kernel::System::Console::BaseCommand::Execute Line: 474
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        ERROR: OTOBO-otobo.Console.pl-Maint::Config::Rebuild-59 Perl: 5.30.0 OS: linux Time: Mon Aug 1 12:18:00 2022

        Message: Loading the YAML string failed: YAML::XS::Load Error: The problem:

        found character that cannot start any token

        was found at document: 1, line: 2, column: 2
        while scanning for the next token at line: 2, column: 2

        Traceback (97058):
        Module: Kernel::System::YAML::Load Line: 125
        Module: Kernel::System::SysConfig::DB::DefaultSettingListGet Line: 1398
        Module: Kernel::System::SysConfig::_GetSettingsToDeploy Line: 5899
        Module: Kernel::System::SysConfig::ConfigurationDeploy Line: 3442
        Module: Kernel::System::Console::Command::Maint::Config::Rebuild::Run Line: 153
        Module: (eval) Line: 480
        Module: Kernel::System::Console::BaseCommand::Execute Line: 474
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        ERROR: OTOBO-otobo.Console.pl-Maint::Config::Rebuild-59 Perl: 5.30.0 OS: linux Time: Mon Aug 1 12:18:00 2022

        Message: YAML data was: "--- |
        [% Data.Salutation | html %]
        [% Data.StdResponse | html %]
        [% Data.Signature | html %]

        [% Data.CreateTime | Localize("TimeShort") %] - [% Data.OrigFromName | html %] [% Translate("wrote") | html %]:
        [% Data.Body | html %]
        "

        Traceback (97058):
        Module: Kernel::System::YAML::Load Line: 133
        Module: Kernel::System::SysConfig::DB::DefaultSettingListGet Line: 1398
        Module: Kernel::System::SysConfig::_GetSettingsToDeploy Line: 5899
        Module: Kernel::System::SysConfig::ConfigurationDeploy Line: 3442
        Module: Kernel::System::Console::Command::Maint::Config::Rebuild::Run Line: 153
        Module: (eval) Line: 480
        Module: Kernel::System::Console::BaseCommand::Execute Line: 474
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        ERROR: OTOBO-otobo.Console.pl-Maint::Config::Rebuild-59 Perl: 5.30.0 OS: linux Time: Mon Aug 1 12:18:00 2022

        Message: Data was only readable pure-perl YAML module, please contact the System Administrator to update this record, as the stored data is still in a wrong format!

        Traceback (97058):
        Module: Kernel::System::YAML::Load Line: 150
        Module: Kernel::System::SysConfig::DB::DefaultSettingListGet Line: 1398
        Module: Kernel::System::SysConfig::_GetSettingsToDeploy Line: 5899
        Module: Kernel::System::SysConfig::ConfigurationDeploy Line: 3442
        Module: Kernel::System::Console::Command::Maint::Config::Rebuild::Run Line: 153
        Module: (eval) Line: 480
        Module: Kernel::System::Console::BaseCommand::Execute Line: 474
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        When I remove the XML file and run update again, it throws no errors and then skin is still usable.

        I have absolutley no idea how to debug this.

        Thanks for any help.

        • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von Marek Soth.
        • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von Marek Soth.
      • #13512
        Marek Soth
        Teilnehmer

          Ok I have found out it has nothing to do with skins.
          The YAML errors are thrown ever second time i run

          sudo su -c “bin/otobo.Console.pl Maint::Config::Rebuild” -s /bin/bash otobo

          first run says OK, every second run it throws errors.

      Ansicht von 1 Antwort-Thema
      • Du musst angemeldet sein, um auf dieses Thema antworten zu können.