Viewing 1 reply thread
  • Author
    Posts
    • #12100
      Rainer Huth
      Participant

      Dockerversion OTOBO_10_1

      Hallo Community,

      bin am verzweifeln und hoffe auf eure Erfahrung.
      Ich bin Neuling bei OTRS/OTOBO und kämpfe jetzt schon stundenlang an einer LDAP-Anbindung bzw an das Active Directory.

      Problem: immer wenn ich mich als ein Domänenuser (über samAccountname) anmelden will, kommt „Authentifizierung erfolgreich, aber in der Datenbank wurde kein Eintrag für den Benutzer gefunden. Bitte kontaktieren Sie Ihren Administrator.“

      Was hab ich gemacht:  zuerst in der GUI über SystemKonfiguration > search *ldap* hab ich die Daten für ldap hinterlegt, dann zusätzlich über die Config.pm. Hier stellt sich bei mir schon die Grundsatzfrage: zuerst hatte ich es über die GUI gemacht, aber in der Config.pm sah ich nichts, wie wenn dies zwei verschiedene Sachen sind. Hab dann aus der Default.pm die ldap-Konfiguration ins config.pm genommen, ausgefüllt, docker neugestartet, aber immer wieder kommt die gleiche Meldung

      Kann mir jemand sagen, wo mein Fehler liegt ?
      – Verständnisschwierigkeit: Unterschied GUI > Config.pm
      –  Net::LDAP is installed > wie kontrolliere ich dies bzw. muss ich hier was manuell installieren.

       

      so sieht aktuell meine config.pm aus (das was ich aus der default.pm eingefügt hatte)

      # —————————————————- #
      # insert your own config settings „here“ #
      # config settings taken from Kernel/Config/Defaults.pm #
      # —————————————————- #
      # $Self->{SessionUseCookie} = 0;
      # $Self->{CheckMXRecord} = 0;

      # —————————————————- #
      # This is an example configuration for an LDAP auth. backend.
      # (take care that Net::LDAP is installed!)
      $Self->{AuthModule1} = ‚Kernel::System::Auth::LDAP‘;
      $Self->{‚AuthModule::LDAP::Host1‘} = ‚dc1.mydomain.local‘;
      $Self->{‚AuthModule::LDAP::BaseDN1‘} = ‚dc=mydomain,dc=local‘;
      $Self->{‚AuthModule::LDAP::UID1′} = ’sAMAccountName‘;

      # Check if the user is allowed to auth in a posixGroup
      # (e. g. user needs to be in a group xyz to use otobo)
      $Self->{‚AuthModule::LDAP::GroupDN1‘} = ‚CN=OTRS-Allow,OU=Funktion,OU=02_GRUPPEN,OU=01_KAPPEL,OU=01_Firmenname,DC=mydomain,DC=local‘;
      $Self->{‚AuthModule::LDAP::AccessAttr1‘} = ‚member‘;
      # for ldap posixGroups objectclass (just uid)
      # $Self->{‚AuthModule::LDAP::UserAttr‘} = ‚UID‘;
      # for non ldap posixGroups objectclass (with full user dn)
      $Self->{‚AuthModule::LDAP::UserAttr1‘} = ‚DN‘;

      # The following is valid but would only be necessary if the
      # anonymous user do NOT have permission to read from the LDAP tree
      $Self->{‚AuthModule::LDAP::SearchUserDN1‘} = ‚CN=IT BindUser,OU=03_Dienste-Admin,OU=00_ADMIN,OU=01_Firmenname,DC=mydomain,DC=local‘;
      $Self->{‚AuthModule::LDAP::SearchUserPw1‘} = ‚geheimespasswort‘;

      # in case you want to add always one filter to each ldap query, use
      # this option. e. g. AlwaysFilter => ‚(mail=*)‘ or AlwaysFilter => ‚(objectclass=user)‘
      # or if you want to filter with a locigal OR-Expression, like AlwaysFilter => ‚(|(mail=*abc.com)(mail=*xyz.com))‘
      $Self->{‚AuthModule::LDAP::AlwaysFilter1‘} = “;

      # in case you want to add a suffix to each login name, then
      # you can use this option. e. g. user just want to use user but
      # in your ldap directory exists user@domain.
      # $Self->{‚AuthModule::LDAP::UserSuffix‘} = ‚@domain.com‘;

      # In case you want to convert all given usernames to lower letters you
      # should activate this option. It might be helpful if databases are
      # in use that do not distinguish selects for upper and lower case letters
      # (Oracle, postgresql). User might be synched twice, if this option
      # is not in use.
      # $Self->{‚AuthModule::LDAP::UserLowerCase‘} = 0;

      # In case you need to use OTOBO in iso-charset, you can define this
      # by using this option (converts utf-8 data from LDAP to iso).
      # $Self->{‚AuthModule::LDAP::Charset‘} = ‚iso-8859-1‘;

      # Net::LDAP new params (if needed – for more info see perldoc Net::LDAP)
      $Self->{‚AuthModule::LDAP::Params‘} = {
      port => 389,
      timeout => 120,
      async => 0,
      version => 3,
      };

      Vielen Dank vorab für eure Hilfe/Unterstützung

    • #12101
      Renée Bäcker
      Participant

      Du hast jetzt nur die Authentifizierung konfiguriert. Was der Fehler sagt: Du hast für das AD/LDAP einen richtigen Benutzernamen und das richtige Passwort dazu eingegeben, aber OTOBO kann mit dem Ergebnis nichts anfangen. Du musst entweder den Agenten vorher in der Datenbank anlegen, oder die Synchronisation konfigurieren

      https://github.com/RotherOSS/otobo/blob/ad6dc0e1e264f9abb7bff3f40fa7b067a6fc5741/Kernel/Config/Defaults.pm#L524

Viewing 1 reply thread
  • You must be logged in to reply to this topic.