Ansicht von 18 Antwort-Themen
  • Autor
    Beiträge
    • #14741

      Hallo

      Ich hab jetzt nach ewigem versuchen den Mailempfang hinzubekommen aufgegeben und jetzt die Ubuntu Desktopversion installiert um Otobo darauf laufen zu lassen. Was aber leider genauso Probleme verursacht.
      Ich bin genau nach der Anleitung vorgegangen, was auf der Ubuntu Serverversion funktioniert hat.

    • #14748
      Stefan Abel
      Moderator

        Hallo,

        kommst du übers Backend (in den web-Container, via mysql auf die DB, etc.) überall drauf? Das sieht aus, als wäre ggf. das DB Passwort falsch? Ist das in der .env eingetragen?

        Viele Grüße
        Stefan

      • #14751
        marcel-graf
        Teilnehmer

          das mit dem Passwort würde ich auch vermuten. Anbei mal ein kleine Anleitung

          An der Stelle wo die Datei docker_compose_env_http bzw. docker_compose_env_https zu .env kopiert wird muss die Datei noch editiert werden, um das DB root Kennwort festzulegen.

          Befehl zum kopieren

          sudo cp -p .docker_compose_env_http .env

          Befehl zum editiren der datei

          sudo nano .env

          (datei editieren -> OTOBO_DB_ROOT_PASSWORD=<your_secret_password>) STRG + X zum beenden/ Y zum speichern

          Gruß Marcel

        • #14752
          marcel-graf
          Teilnehmer

            Anbei auch noch eine Install Schritt für Schritt Doku, so wie ich das Otobo per Docker auf Ubuntu Server immer installiere.

            — Install Ubuntu Server VM — 20.04.5

            [X] aktualisieren auf neuen installer
            [X] install open SSH Server
            —————————————–
            sudo apt update
            sudo apt upgrade

            sudo apt install net-tools

            — Zeitzone Einstellen —

            timedatectl list-timezones
            sudo timedatectl set-timezone Europe/Berlin
            prüfen mit “date” bzw. “timedatectl”

            —- Install Docker —

            sudo apt-get install git docker docker-compose curl
            sudo systemctl enable docker

            sudo apt update
            sudo apt upgrade

            — otobo install —
            cd /opt

            sudo git clone https://github.com/RotherOSS/otobo-docker.git –branch rel-10_1 –single-branch

            ls otobo-docker # just a sanity check, README.md should exist

            cd /opt/otobo-docker

            sudo cp -p .docker_compose_env_http .env

            sudo nano .env (datei editieren -> OTOBO_DB_ROOT_PASSWORD=<your_secret_password>) STRG + X zum beenden/ Y zum speichern

            sudo docker-compose up –detach

            sudo docker-compose ps
            sudo docker volume ls

            Run the OTOBO installer at http://yourIPorFQDN/otobo/installer.pl

            — Schritt 1 —
            durchklicken
            — Schritt2 —
            installer durchklicken -> MYsql ->neue DB

            generiertes Kennwort speichern: bgZ0uDD07U6pZlhW

            Meldung Datenbank erfolgreich erstellt

            — Schritt 3 —
            http type = http or https
            FQDN und weitere felder füllen

            Email Konfigurtation überspringen -> kommt später

            ———————————————
            Startseite:
            http://yourIPorFQDN/otobo/index.pl
            Benutzer:
            root@localhost
            Password:
            OCu283OQ…….

            Wenn im System eingeloogt unter Admin-> Systemkonfiguration nach SMTP Suchen und dort die entsprechenden Einstellungen vornehmen.

             

             

             

            • #14756

              Danke! ich hab alles so gemacht wie oben beschriben. Hab die VM zurückgesetzt und nochmal von neuem. Ich bekomme die gleiche Meldung.

          • #14757

            Ich hab nochmal über einen anderen Texeditor(Geany) und auch über den Filemanager die Versteckten Dateien eingeblendet und mir dort die Datei über den standard Texteditor aufgemacht. Das Passwort ist eindeutig eingetragen.

          • #14758
            marcel-graf
            Teilnehmer

              Hallo andrei756,

              verstehe ich das Richtig, du willst ein POP/IMAP Konto abholen und das funktioniert nicht?

              Was ist das für ein Anbieter? Wurden die Abholung mit anderen Konten (mal ein bei skymail.de einegrichtet als Beispiel) getestet?

              Gruß Marcel

               

               

            • #14759

              Ich habe das Thema bereits in einem anderen Thread aufgemacht. Aber das wäre mein nächstes Problem wenn ich die Installation mit Ubuntu DesktopVersion hinbekommen sollte(außer es verhält sich gleich wie bei der Serverversion).
              Ich habe google/gmx und office 365 für den Mailversand und Empfang probiert. Nichts davon hatte funktioniert(ich habe das gmx Konto über Thunderbird probiert, da ging es auf anhieb) . Schlussendlich hat es über den lokalen Exchange funktioniert, aber nur der Versand, sobald ich ein Postfach verwendet habe gab es weiterhin kein Empfang.

              Aber jetzt komme ich nicht mal mehr so weit.

            • #14760
              marcel-graf
              Teilnehmer

                Für Office 365 hast du das Otobo Paket/Plugin “MailAccount-OAuth2” installiert und nach der Anleitung wurde das entsprechend eingerichtet?

                In folgendem Post gibt es die Anleitung https://otobo.de/de/forums/topic/probleme-mit-imap-smtp-ms365-host/

                Installiere doch nochmal ein zweites System nach der obigen Anleitung.  Da könnte ich das ggf. gegen testen. Als User nimm bitte mal einfach “otobo”.

                (Siehe Bild)

                Gruß Marcel

                 

                • #14764

                  Danke. Ich kann allerdings weiterhin das System nicht verwenden weil ich an dem Backend Error hänge.

                  Hab mir den Thread angeschaut, man kann aber die Lösung nicht öffnen zu dem OAuth2 Thema.

                  Sobald alles läuft können wir das gerne testen.

              • #14762
                marcel-graf
                Teilnehmer

                  Ich kann auch ohne Probleme per POP3 ein Testkonto bei Mail.de abholen.

                • #14765
                  Grit Rother
                  Administrator
                  • #14772
                    marcel-graf
                    Teilnehmer

                      Hallo andrei756,

                      wir nutzen intern auch nur http. Bei uns hat es geklappt, indem wir in der Bestätigungs URL aus dem https ein http gemacht haben.

                      Gruß Marcel

                       

                       

                    • #14777
                      marcel-graf
                      Teilnehmer

                        Genau, im Azure ist HTTPS schon richtig. Im Otobo wird dann unter Email Konten das Office365 Konto hinzugefügt.

                        Hier muss man sich dann mit dem User und Kennwort Authentifizieren und wird dann auf einen Link weitergeleitet, da muss man das https auf http ändern.

                         

                        Gruß Marcel

                        • #14783

                          Sobald ich das Emailkonto für den Host bearbeite und da den Typ IMAP Oauth auswähle der neu ist… dann komme ich 1x auf eine Microsoft Authentifizierungsseite, das hat aber nicht funktioniert.

                           

                          Beim Zweiten versuch komme ich gleich auf “Diese Webseite ist nicht erreichbar”-> wenn ich aber hier das s von https entferne dann komme ich wider zum Login von Otobo.

                           

                          Bin das Tutorial jetzt 5 mal durch aber es geht einfach nicht.

                      • #14785
                        marcel-graf
                        Teilnehmer

                          Beim Zweiten versuch komme ich gleich auf „Diese Webseite ist nicht erreichbar“-> wenn ich aber hier das s von https entferne dann komme ich wider zum Login von Otobo.

                          –> was kommt denn, wenn du dich dann dort mit deinem User wieder einloggst? Kommst du dann zu der Postfachoberfläche? Sind die Daten übernommen? Eventuell im Postfach nochmal auf “Speichern und abschließen” klicken

                          Im Otobo muss dann die Meldung kommen “Mail account updated! “

                          • #14786

                            Ich habe mich dann mit dem root@localhost von otobo wieder angemeldet. Es wurde leider nichts übernommen

                             

                            Hier noch ein paar screenshots der aktuellen Einstellungen:
                            Hab einen Kollegen auch drüberschauen lassen, aber er hat auch nichts abweichendes gefunden.
                            1.

                            2.

                            3.

                            4.

                            5.

                            6.

                            7.

                        • #14787
                          marcel-graf
                          Teilnehmer

                            Die Einstellungen sehen Grundsätzlich ok aus. Leider hab ich im Azure da keine vollen Admin Berechtigungen.

                            Enabled for usrs to sign-in ist bei uns auch aktiv.

                            Bei 5. haben wir noch vertraut (ja) stehen, bei 6.und 7. ist auch ok.

                            IMAP bzw. POP3 ist bei dem Userkonto aktiviert?

                             

                             

                          • #14789
                            marcel-graf
                            Teilnehmer

                              Du kannst zur not auch mal im Znuny Forum schauen, da gibt es auch immer hilfreiche tipps.

                              https://community.znuny.org/viewtopic.php?p=176210

                               

                              Gruß Marcel

                            • #14795
                              marcel-graf
                              Teilnehmer

                                google und gmx habe ich nicht getestet. Aber ein Testaccount bei mail.de zB hat bei mir auch funktioniert.

                                Ja, das “Enabled for users“? ist in Azure

                                • #14806

                                  Ich wäre dir sehr dankbar wenn du dieses Konto für mich testen könntest ob das bei dir funktioniert. Also der Mailversand und Empfang. Wenn das bei dir geht dann liegt das Problem nicht bei Otobo was diese Postfächer von Google usw betrifft.

                                  benutzername: hyunknownuser123@gmail.com

                                  passwort : hyunknownuser123#+

                              • #14799
                                marcel-graf
                                Teilnehmer

                                  Kannst du denn mal ein Konto bei Mail.de oder Skymail.de einrichten die die Abholung testen, um mal zu sehen, ob das System läuft.

                                  • #14808

                                    Hallo

                                    Danke für das TEsten des Gmail Kontos.

                                    ich meld mich noch bezüglich des Skymail. Kontos

                                     

                                     

                                     

                                     

                                • #14807
                                  marcel-graf
                                  Teilnehmer

                                    Das Gmail funktioniert auch bei mir nicht.

                                    Da muss bestimmt noch etwas im Konto aktiviert werden.

                                    • #14810

                                      Unglaublich mit Skymail funktioniert es. ich danke dir vielmals.

                                      Kann ich darüber auch den Mailversand einrichten? Habe keine SMTP Host Daten gefunden.

                                  • #14813
                                    marcel-graf
                                    Teilnehmer

                                      ganz unten steht etwas von smtp. kann ich morgen aber mal testen.

                                      Verwenden Sie folgende Daten, um Ihre E-Mail Anwendung einzurichten:
                                      IMAP
                                      Posteingang: skymail.de
                                      Postausgang: skymail.de
                                      Verbindungssicherheit: STARTTLS

                                      POP3
                                      Posteingang: skymail.de
                                      Postausgang: skymail.de
                                      Verbindungssicherheit: STARTTLS

                                      Postfach Ports
                                      POP3: 110 unverschlüsselt oder verschlüsselt mit STARTTLS
                                      IMAP: 143 unverschlüsselt oder verschlüsselt mit STARTTLS
                                      SMTP: 587

                                       

                                      • #14825

                                        Ja genau das habe ich auch gefunden aber da fehlen noch die übrigen Einträge die ich dann in Otobo eintragen soll.

                                  Ansicht von 18 Antwort-Themen
                                  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.