Schlagwörter: 

Ansicht von 8 Antwort-Themen
  • Autor
    Beiträge
    • #14336
      Tester Player
      Teilnehmer

        Hallo Community,

        ich habe erfolgreich OTOBO aufgesetzt mit allen Einstellungen für Maileingang jedoch beim Mailausgang funktioniert das leider garnicht.

        Folgende Einstellungen sind gesetzt.

        SendmailModule: SMTPTLS

        SendmailModule::AuthPassword: Passwort

        SendmailModule::AuthUser: Mail

        SendmailModule::Host: smtp.office365.com

        SendmailModule::Port: 587

        AdminEmail: Mail

         

        Mails werden nicht gesendet und die Kommunikationsliste ist überfüllt

        Die MailQueue habe ich in der Tabelle gelöscht aber es werden immer dann wieder viele Mails. Komme echt nicht mehr weiter.

        Habt Ihr Ideen?

        Beste Grüße

      • #14598
        marcel-graf
        Teilnehmer

          Hallo,

          ich würde doch als erstes einmal testen ob der Versand über ein SMTP Test Tool funktioniert. (Da gibt es ja mehrere, Beispiel “SMTP Diag”)

          Wenn das mit dem Test funktioniert, dann nochmal im OTOBO in der Systemkonfiguration nach SMTP suchen und die folgenden Felder auf korrekte Werte prüfen:

          SendmailModule

          SendmailModule::AuthPassword

          SendmailModule::AuthUser

          SendmailModule::Host

          SendmailModule::Port

           

          Gruß Marcel

           

          • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von marcel-graf.
        • #14654

          Hallo

           

          Ich hab gerade ein kleines Problem beim Mailempfang. Egal was ich da eintrage, das Kommunikationsprotokoll-Kontostatus meldet mir, dass es nicht funktioniert.

          Ich habe es sowohl mit Pop als auch mit Imap von Google in der Emailkontenverwaltung versucht, aber nichts scheint zu funktionieren. Sollte ich vielleicht noch irgendwas aktivieren?

          Folgendes habe ich eingetragen
          Typ: hier habe ich die Standard imap und pop sowie die mit “S” am Ende- TLS bisher noch nicht

          PAsswort: Hier habe ich das Kontopasswort probiert und auch das für sichere Apps

          Benutzername: emailkonto@gmail.com

          Host: pop.gmail.com bzw. imap.gmail.com

           

        • #14657
          marcel-graf
          Teilnehmer

            Hallo andrei756,

            funktioniert denn das Abholen von Emails mit einem Email Client (Outlook/ Mozilla Thunderbird oder sonstigem Email Programm)?

            Wir haben bei uns bei einigen Konten POP3TLS/IMAPTLS ausgewählt. Es kann natürklich sein, dass man bei Gmail noch extra was freischalten muss, deshalb die Frage nach dem Test mit einem anderen Email Client.

            Gruß Marcel

             

            • #14658

              Ich hab es jetzt auch noch mal mit POP3TLS probiert aber beim Kontostatus ist immer ein “X”. In Thunderbird hat das Abholen der Mails ohne Probleme funktioniert.

               

               

          • #14680
            marcel-graf
            Teilnehmer

              Hallo andrei756,

              was steht dazu im Kommunikationsprotokoll in der Kommunikationsliste?

              Gruß Marcel

               

              • #14681

                Ich habe aktuell den Versand auch probieren wollen, aber das geht leider auch nicht, da bin ich wie oben vorgegangen und habe die Daten entsprechen ausgefüllt. Dann wollte ich ein Email Ticket erstellen. Da kam diese Meldung

                Bezüglich Kommunikationsprotokoll scheint das noch eine Offene Verbindung zu dem zuvor getestetem imap.google.com besteht.

                Kann es sein das am Server selbst(Ubuntu VM) da etwas gesperrt ist. Hab versucht den Versand zu testen( Link) aber mein Ubuntu kennt diesen Befehl anscheinend nicht.
                Kann es sein das irgendwelche Ports da gesperrt sind?

            • #14703

              Hat vielleicht noch jemand einen Tipp für mich was ich da noch prüfen könnte damit wir das Ticketsystem nutzen können. Wir haben jetzt auch die IP der Linux VM geändert in der hoffnung dass das was bringt. Leider ohne Erfolg.

            • #14711
              marcel-graf
              Teilnehmer

                Hallo Andrei756,

                ist das eine Docker basierende installation oder wurden alle Pakete selbst installiert?

                Ich nehme an das die Netzwerkanbindung funktioniert? Ein Ping von dem Server aus zu Google funktioniert bzw. per Putty kannst du dich auch auf den Ubuntu Server verbinden?

                Für eine normale (nicht Docker) installation hatte ich mir mal folgende Befehlsdoku erstellt. Die ist aber schon älter, da wir aktuell nur Docker nutzen. Eventuell mit der Otobo Doku abgleichen.

                ##################################
                otobo install
                ##################################
                ####proxmox create container -> Ubuntu 20.10

                sudo apt update
                sudo apt upgrade

                sudo apt install net-tools  # installiert netzwerktools Ping usw.

                Zeitzone Einstellen:
                timedatectl list-timezones
                sudo timedatectl set-timezone Europe/Berlin
                prüfen mit “date” bzw. “timedatectl”

                ##################################
                Schritt 1: OTOBO entpacken und installieren
                ##################################
                root>
                mkdir /opt/otobo-install # Create a temporary install directory
                cd /opt/otobo-install # Change into the update directory
                wget https://ftp.otobo.org/pub/otobo/otobo-latest-10.0.tar.gz # Download he latest OTOBO 10 release
                tar -xzf otobo-latest-10.0.tar.gz # Unzip OTOBO
                ls -a # Verzeichnisinhalt anzeigen um Otobo Version zu prüfen
                cp -r otobo-10.x.x /opt/otobo # Copy the new otobo directory to /opt/otobo

                ##################################
                Schritt 2: Ergänzende Programme und Perl-Module installieren
                ##################################
                apt-get install perl

                perl /opt/otobo/bin/otobo.CheckModules.pl -list

                /opt/otobo/bin/otobo.CheckModules.pl -inst
                —-
                apt-get install -y libarchive-zip-perl libtimedate-perl libdatetime-perl usw…… # Rückgabe von tobo.CheckModules.pl -inst wird mit dem Befehl installiert
                —-
                ##################################
                Schritt 3: OTOBO-Benutzer anlegen
                ##################################
                root>
                useradd -r -U -d /opt/otobo -c ‘OTOBO user’ otobo -s /bin/bash
                usermod -G www-data otobo

                adduser otobo sudo

                cp /opt/otobo/Kernel/Config.pm.dist /opt/otobo/Kernel/Config.pm

                ##################################
                Schritt 5: Apache-Webserver konfigurieren
                ##################################
                root>
                apt-get install apache2 libapache2-mod-perl2

                a2enmod perl
                a2enmod deflate
                a2enmod filter
                a2enmod headers

                ——————————————-
                Apache ohne SSL-Unterstützung konfigurieren
                ——————————————–
                cp /opt/otobo/scripts/apache2-httpd.include.conf /etc/apache2/sites-enabled/zzz_otobo.conf
                systemctl restart apache2

                ##################################
                Schritt 6: Dateiberechtigungen anpassen
                ##################################
                root>
                /opt/otobo/bin/otobo.SetPermissions.pl

                ##################################
                Schritt 7: Datenbank anlegen
                ##################################
                root>
                apt-get install mysql-server

                mysql -u root
                mysql> ALTER USER ‘root’@’localhost’ IDENTIFIED WITH mysql_native_password BY ‘otobo******’;
                mysql> exit

                -> MySQL Config (mysqld.cnf) anpassen
                cd /etc/mysql/mysql.conf.d
                ls -a
                vi mysqld.cnf (folgende Einträge dem Config File hinzufügen/bearbeiten)
                ——————————
                max_allowed_packet = 64M
                innodb_log_file_size = 512M
                query_cache_size = 32M ->beim setzen vom query_cache_size startet mySQL nicht mehr
                ——————————

                root>
                apt-get install mysqltuner
                mysqltuner –user root –pass otobo*******

                service mysql restart

                ##################################
                Schritt 8: Elasticsearch-Cluster aufsetzen
                ##################################
                ->JDK-Installation
                root>
                apt update
                apt install openjdk-8-jdk

                https://phoenixnap.com/kb/install-elasticsearch-ubuntu

                -> Elasticsearch-Installation

                apt-get install gnupg

                root>
                wget -qO – https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add –
                echo “deb https://artifacts.elastic.co/packages/7.x/apt stable main” | sudo tee /etc/apt/sources.list.d/elastic-7.x.list
                apt update
                apt -y install elasticsearch

                ##################################
                Elasticsearch-Modul installieren
                ##################################
                -> Plugins

                root>
                /usr/share/elasticsearch/bin/elasticsearch-plugin install –batch ingest-attachment
                /usr/share/elasticsearch/bin/elasticsearch-plugin install –batch analysis-icu

                ##################################
                Elasticsearch konfigurieren
                ##################################

                vi /etc/elasticsearch/jvm.options

                change to
                -Xms4g -> startet mit 4g nicht -> zurück zu 1g
                -Xmx4g -> startet mit 4g nicht -> zurück zu 1g

                service elasticsearch status
                systemctl restart elasticsearch

                ##################################
                Schritt 8: Grundlegende Systemkonfiguration (Otobo über Webbrowser installieren)
                ##################################

                http://localhost/otobo/installer.pl

                ————-
                Passwort vom otobo user ändern ;generiertes Passwort – PzzxQsS********
                sudo passwd otobo****
                Kennwort otobo****

                root>
                cd /opt/otobo/var/cron/
                root> for foo in *.dist; do cp $foo basename $foo .dist; done

                otobo> /opt/otobo/bin/otobo.Daemon.pl start
                otobo> cd /opt/otobo/
                otobo> bin/Cron.sh start

                ##################################
                Schritt 12: Bash Auto-Completion einrichten (optional)
                ##################################
                otobo>
                source /opt/otobo/.bash_completion

                ##################################
                Elasticsearch Test /suche geht nicht
                ##################################
                sudo systemctl status elasticsearch

                Falls es nicht läuft, müsste man es mit wieder aktivierien.
                sudo systemctl start elasticsearch

                Um es automatisch beim booten zu starten wäre der Befehl:
                sudo systemctl enable elasticsearch

                Wenn es läuft und nicht funktioniert, könnte man als schnellen Test die OTOBO-Daten neu in Elasticsearch einlesen, und dabei die Indizes neu anlegen. Das geht mittels der otobo.Console.
                In der Shell muss bei einer Standardinstallation (d.h. nicht via Docker) folgendes ausgeführt werden:

                sudo su otobo
                cd /opt/otobo
                bin/otobo.Console.pl Maint::Elasticsearch::Migration

                Gruß Marcel

                • #14713

                  Ich habe das über Docker installiert. Mailversand geht mittlerweile über die IP des lokalen Exchange.

                  Ping kann ich aktuell nicht testen weil ich seit heute am server nichts eingeben kann… da kommt dort wo das Passwort ein zugeben ist “cloud init running modules config usww..”

                  Mit Putty komme ich nicht drauf.

              • #14714
                marcel-graf
                Teilnehmer

                  Ist das eine Ubuntu Serverversion? Wurde da beim Installieren oder im Nachgang  SSH installiert?

                  • #14725

                    Ich habe im vSphere Client eine VM erstellt und dort wurde mir Ubuntu 64 bit angezeigt. Ich nehm mal an das es sich um die Serverversion handeln muss.
                    SSH habe ich noch nicht installiert.

                • #14730

                  Also zusammenfassend funktioniert bei mir kein Posteingangskonto.
                  Ich habe GMX, Gmail, Outlook365 und ein exchange Posteingang probiert.

                  Dadurch das man da keinen Port angeben kann liegt vielleicht das Problem daran. Was meint ihr?

              Ansicht von 8 Antwort-Themen
              • Du musst angemeldet sein, um auf dieses Thema antworten zu können.