Viewing 3 reply threads
  • Author
    Posts
    • #10911
    • #11755
      Markus Neundlinger
      Participant

      Hallo

      Falls es noch benötigt wird oder für andere die das gleiche Problem haben, anbei ein Fileformat welches bei mir funktioniert hat.  Ursprünglicher Code von Otrs hier: https://gist.github.com/eyazi/501f70bbee206c66ea02b58bf3bfd5e0

      lg Markus

      <?xml version="1.0" encoding="utf-8" ?>
      <otobo_config version="2.0" init="Application">
      <Setting Name="AgentLogoCustom###YourSkinName" Required="0" Valid="1">
      <Description Translatable="1">The logo shown in the header of the agent interface for the skin "YourSkinName". See "AgentLogo" for further description.</Description>
      <Navigation>Frontend::Agent</Navigation>
      <Value>
      <Hash>
      <Item Key="URL">skins/Agent/YourSkinName/img/logo_bg.png</Item>
      <Item Key="StyleTop">21px</Item>
      <Item Key="StyleRight">29px</Item>
      <Item Key="StyleHeight">55px</Item>
      <Item Key="StyleWidth">230px</Item>
      </Hash>
      </Value>
      </Setting>
      <Setting Name="Loader::Agent::Skin###001-YourSkinName" Required="0" Valid="1">
      <Description Translatable="1">YourSkinName description.</Description>
      <Navigation>Frontend::Base::Loader</Navigation>
      <Value>
      <Hash>
      <Item Key="InternalName">YourSkinName</Item>
      <Item Key="VisibleName" Translatable="1">Your skin name</Item>
      <Item Key="Description" Translatable="1">YourSkinName description.</Item>
      <Item Key="HomePage">www.YourCompany.com</Item>
      </Hash>
      </Value>
      </Setting>
      </otobo_config>

    • #11768
      Benjamin Mehlhorn
      Participant

      Hallo Markus,

      vielen Dank für Deine XML. Ich stehe gerade vor einem ähnlichen Problem und habe auch Deine XML probiert, aber OTOBO 10.0 lädt bei mir keinen anderen Skins.

      Die Skin-Dateien sind abgelegt unter:
      /opt/otobo/var/httpd/htdocs/skins/Agent/custom

      CustomSkin.xml unter:
      /opt/otobo/Kernel/Config/Files/XML/
      Enthalten ist dann <Item Key=“InternalName“>custom</Item>

      Habe anschließend auch die Konfiguration neu geladen über:
      otobo.Console.pl Maint::Config::Rebuild

      In der Systemkonfiguration unter Loader::Agent::Skin wird der Skin auch aufgeführt. Wenn ich jetzt jedoch den Skin „Benutzerdefiniert“ in meinen persönlichen Einstellungen auswähle, speichere und die Seite neu lade, ändert sich nichts an der Optik.
      Ich habe auch testweise mal den Skin „ivory“ aus einer OTRS-Community-Version reinkopiert – der OTRS-Skin erscheint dann auch in der Auswahl, aber auch hier ändert sich nach der Auswahl des Skins und dem Neuladen der Seite optisch nichts.

      Was mich wundert ist, dass OTOBO eigentlich auch ein Verzeichnis „css-cache“ unter „/opt/otobo/var/httpd/htdocs/skins/Agent/custom“ aufbauen müsste, was es nicht tut.

      Hast Du vielleicht noch eine Idee?

      Danke,
      Benjamin

    • #11771
      Benjamin Mehlhorn
      Participant

      Kurze Rückmeldung: Es waren Berechtigungsprobleme, Berechtigungen auf den Skin-Ordner korrekt gesetzt und schon klappt es auch mit Skins.

      Setzen musste ich:

      chmod 2775 -R /opt/otobo/var/httpd/htdocs/skins/Agent/custom
Viewing 3 reply threads
  • You must be logged in to reply to this topic.