Topic Resolution: Resolved

Schlagwörter: 

Ansicht von 5 Antwort-Themen
  • Autor
    Beiträge
    • #16218
      marbert
      Teilnehmer

        Hallo,

        bei der Installation auf einem CentOS 8 Stream unter Otobo 10.0.19 bekomme ich folgende Fehlermeldung:

        $ otobo.Console.pl Admin::Package::Install MailAccount-OAuth2-10.0.2.opm

        Installing package...
        Notice: Install /opt/otobo/Custom/Kernel/Modules/AdminMailAccount.pm (660)!
        Notice: Install /opt/otobo/Custom/Kernel/Output/HTML/Templates/Standard/AdminMailAccount.tt (660)!
        Notice: Install /opt/otobo/Custom/Kernel/System/MailAccount.pm (660)!
        Notice: Install /opt/otobo/Custom/Kernel/System/MailAccount/POP3.pm (660)!
        Notice: Install /opt/otobo/Kernel/Config/Files/XML/MailAccountOAuth2.xml (660)!
        Notice: Install /opt/otobo/Kernel/Language/de_MailAccountOAuth2.pm (660)!
        Notice: Install /opt/otobo/Kernel/System/MailAccount/IMAPOAuth2.pm (660)!
        Notice: Install /opt/otobo/Kernel/System/MailAccount/POP3OAuth2.pm (660)!
        Notice: Install /opt/otobo/Kernel/System/OAuth2/MailAccount.pm (660)!
        Notice: Install /opt/otobo/Kernel/System/OAuth2.pm (660)!
        Notice: Install /opt/otobo/doc/en/Mailaccount-OAuth2.pdf (660)!
        Notice: Install /opt/otobo/var/httpd/htdocs/js/Core.Agent.Admin.MailAccount.js (660)!
        ERROR: OTOBO-otobo.Console.pl-Admin::Package::Install-20 Perl: 5.26.3 OS: linux Time: Thu Jan 4 19:42:35 2024

        Message: Unknown data type 'TEXT'!

        Traceback (8200):
        Module: Kernel::System::DB::_TypeCheck Line: 2025
        Module: Kernel::System::DB::SQLProcessor Line: 1180
        Module: Kernel::System::Package::_Database Line: 3610
        Module: Kernel::System::Package::PackageInstall Line: 642
        Module: Kernel::System::Console::Command::Admin::Package::Install::Run Line: 90
        Module: (eval) Line: 468
        Module: Kernel::System::Console::BaseCommand::Execute Line: 462
        Module: Kernel::System::Console::InterfaceConsole::Run Line: 88
        Module: bin/otobo.Console.pl Line: 35

        Notice: ALTER TABLE mail_account ADD oauth2_profile VARCHAR (45) NULL
        Notice: UPDATE mail_account SET oauth2_profile = '0' WHERE oauth2_profile IS NULL
        Notice: ALTER TABLE mail_account CHANGE oauth2_profile oauth2_profile VARCHAR (45) DEFAULT '0' NULL
        Notice: CREATE TABLE auth_token (
        account_type VARCHAR (25) NOT NULL,
        account_id VARCHAR (150) NOT NULL,
        token_type VARCHAR (20) NOT NULL,
        token TEXT NOT NULL
        )
        Done.

        Es gibt dazu im englischen Forum auch schon ein Topic, aber ich traue der Sache nicht so ganz, dass man diese Meldung ignorieren kann. https://otobo.de/en/forums/topic/unknow-type-text-installing-oauth2-on-otobo-10-0-16/

        Eventuell führt der Fehler dann ja dazu, dass folgende Aktionen nicht mehr ausgeführt werden. Weiß jemand wie man den Fehler verhindern kann?

         

      • #16219
        marcel-graf
        Teilnehmer

          Hallo marbert,

          wir haben die OAuth2 Version 10.1.2 im Einsatz nutzen aber auch die Otobo 10.1.8

          Welche Version wird denn in der Paketverwaltung aktuell angeboten?

          Gruß Marcel

           

           

        • #16220
          marbert
          Teilnehmer

            Da wir noch den 10.0er-Zweig verwenden, gehe ich davon aus, dass wir auch das 10.0er-AddOn installieren müssen, oder? Unser System hat keinen direkten Onlinezugang, deswegen lade ich das AddOn von der Webseite herunter und installiere es über die Kommandozeile.

          • #16221
            marcel-graf
            Teilnehmer

              In der Moduldokumentation steht folgendes:

              This module was programmed for OTOBO 10.0.x.

              Sollte daher auch mit der 10.0.19 funktionieren.

              Gruß Marcel

            • #16224
              marbert
              Teilnehmer

                Ich vermute da eher, dass das beim Wechsel auf 10.1 nicht angepasst wurde ;-)

                Ansonsten würde mich auch verwundern warum die 10.0er-Version nach der 10.1er-Version released wurde bzw. warum dann überhaupt:

                MailAccount-OAuth2-10.0.1.opm 03-May-2022 05:08 465K
                MailAccount-OAuth2-10.0.2.opm 19-Jul-2023 08:30 465K
                MailAccount-OAuth2-10.1.1.opm 03-May-2022 05:08 465K
                MailAccount-OAuth2-10.1.2.opm 11-Jul-2023 07:14 466K

                Aktuell kann ich aber leider nicht testen ob das einen Unterschied machen würde.

              • #16317
                marbert
                Teilnehmer

                  Wenn ich anhand der Fehlermeldung in die Datei /opt/otobo/Kernel/System/DB.pm in Zeile in Zeile 2025 schaue, dann finde ich die Ursache in sub _TypeCheck:

                  if (
                  $Tag->{Type}
                  && $Tag->{Type} !~ /^(DATE|SMALLINT|BIGINT|INTEGER|DECIMAL|VARCHAR|LONGBLOB)$/i
                  )

                  ==> anscheinend ist der Datentyp “TEXT” gar nicht erlaubt. Wundere mich nur warum dass dann nicht bei allen eine Fehlermeldung wirft, denn in den aktuellen Git-Quellen steht das so auch drinnen. Ausgewertet wird der Returnwert von TypeCheck nicht. Von daher kann man die Meldung wohl ignorieren.

              Ansicht von 5 Antwort-Themen
              • Du musst angemeldet sein, um auf dieses Thema antworten zu können.