Viewing 1 reply thread
  • Author
    Posts
    • #10438
      B Weik
      Participant

      Hallo,

      wir haben bislang OTRS im Einsatz. Bei der Migrationsvorbereitung auf unser neues DB System fiel auf, das OTRS nicht kompatibel mit MariaDB 10.5 zu seien scheint. Neben der allgemeinen Inkompatibilität mit MySQL 8 wegen den Keywords, gibt es auch den Fehler Could not create the deployment in the DB!

      Daraufhin habe ich mal OTOBO probiert, jedoch habe ich hier den gleichen Fehler. Beim Ändern von Einstellungen in der SysConfig, schlägt das Deployment der Einstellungen dann immer mit der oben genannten Fehlermeldung fehl. Die Daten scheinen zwar doch übernommen zu werden, aber es wird immer als Fehlgeschlagen markiert.

      Ich bin leider nicht so wirklich auf den Grund gestoßen, woran das überhaupt liegen könnte. Hat das Problem evtl. schon mal jemand anderes beobachtet?

    • #10559
      Stefan Rother
      Keymaster

      Hallo Herr Weik,

      OTOBO ist zu 100% kompatibel zu MySQL 8, wir haben alle (bekannten) Probleme behoben. Ich denke auch nicht, dass es sich um ein Datenbankproblem handelt, aber das ist schwierig zu sagen aus der Ferne.

      Interessant wären weitere Fehlermeldungen, warum das Deployment fehlschlägt. Ich denke eher an korrupte Konfigurationsoptionen. Das Problem sollte auf jeden Fall vor der Migration auf OTOBO behoben werden.

      Sie könnten mal testen, was die Ausgabe ist wenn Sie von der Konsole folgende Befehle ausführen:

      bin/otrs.Console.pl Admin::Config::ListInvalid

      bin/otrs.Console.pl Admin::Config::FixInvalid

      bin/otrs.Console.pl Maint::Config::Rebuild (eventuell mit –force)

      Gerne können wir den Fehler für Sie beheben und auch die Migration durchführen. Senden Sie bitte bei Interesse einfach eine kurze E-Mail an hallo@otobo.de.

      Schöne Grüße aus Bayern,

      Stefan Rother

      Team OTOBO

       

       

Viewing 1 reply thread
  • You must be logged in to reply to this topic.