Ansicht von 3 Antwort-Themen
  • Autor
    Beiträge
    • #14253
      Michael Wielitsch
      Teilnehmer

        Hallo liebe Community!

        Ich bin Umsteiger von OTRS zu Otobo und habe die Version 10.1.5 installiert. Ich möchte gerne via Subdomain die Portale für Agents und Customer trennen und erreichen. Da in Otobo der Aufbau etwas anders ist, komme ich nicht so ganz auf eine Lösung.

        Derzeit habe ich eine Standardinstallation durchgeführt wie in https://doc.otobo.de/manual/installation/10.1/en/content/installation.html#configure-apache-without-ssl-support beschrieben. Ich habe im Forum einen Thread gefunden aus dem Jahr 2020 – Using Subdomain | OTOBO – aber das funktioniert nicht.

        Was muss ich tun, damit ich die aktuellste Version via Subdomains und OHNE dem Zusatz /otobo öffnen kann? Also http://subdomain1.fqdn oder http://subdomain.fqdn

        Danke & lg, Michael

      • #14270
        Michael Wielitsch
        Teilnehmer

          Ich push das mal… Hat das Thema denn niemand?

        • #14271
          Stefan Rother
          Administrator

            Hallo Michael,

            ich kann Dir die genaue Apache Konfiguration auch nicht sagen, das müsste ich selbst erarbeiten für Apache.

            Aber eigentlich ist das Vorgehen meist nicht so Sinnvoll, denn Du kannst in OTOBO nur ein FQDN verwenden. Und sobald OTOBO Links verschickt, ist immer ein FQDN enthalten.

            Ich würde den Kundenbereich über https://subdomain1.fqdn verfügbar machen und den Agenten Bereich über https://subdomain1.fqdn/otobo/index.pl lassen.

            Aber bitte verwende OTOBO nicht ohne SSL Verschlüsselung. Diese Doku ist für Testsysteme indiziert, aber bitte nicht Produktiv (Auch wenn das System vielleicht nicht nach Extern erreichbar ist).

            Wenn Du Dich da nicht so gut auskennst, würde ich OTOBO per Docker installieren, da ist dann schon alles vorkonfiguriert.

            Schöne Grüße,

            Stefan
            Team OTOBO

            • #14313
              Michael Wielitsch
              Teilnehmer

                Hallo Stefan,

                danke für die Info und Erklärung. Dann werde ich mir das entsprechend anders zurechtlegen. Aber wenn ich zumindest die Umleitung zu /otobo/… wegbekomme, wäre das schon mein ein Anfang. Ist das wenigstens möglich? ALso dann wäre das so:

                https://domain.fqdn/index.pl and http://domain.fqdn/customer.pl

                Wenn das geht, dann bin ich schon zufriedener :-)

                Danke & lg, Michael

            • #14323
              Andreas Brandts
              Teilnehmer

                Hallo Michael,

                 

                doch das Thema haben sicherlich viele hier, nur ist es eben sehr anspruchsvoll und geht nicht so leicht von der Hand.

                Ich denke, dass das größte Problem darin liegt die otobo-web, bzw. die CGI dann richtig umzubiegen.

                 

                Ich würde es auch toller finden, wenn man die index.pl und customer.pl nicht über die selbe Domäne, bzw. das selbde Dokumenten-Root hätte. Das macht Vieles einfacher aber das wurde damals noch nicht bedacht.

                 

                Wie dem auch sei, ich fühle mich im Apache2 sehr zu hause und werde das Thema einmal durchgehen und dann hier posten.

                 

                PöSö:

                Übrigens ist die SSL-Config von dem regulären vHost abhänging, so wie ich das herausgefunden habe. Sprich, deaktiviert man die port 80 config, geht auch die SSL config down (Wenn ich mich korrekt erinnere), was meiner Meinung nach eigentlich nicht sein sollte.

                Das ist zunächst das größte Problem, welches gelöst werden müsste. Da bräuchte es aber echt einen Apache2 Profi.

                 

                LG
                Andreas

            Ansicht von 3 Antwort-Themen
            • Du musst angemeldet sein, um auf dieses Thema antworten zu können.