Topic Resolution: Resolved

Schlagwörter: 

Ansicht von 1 Antwort-Thema
  • Autor
    Beiträge
    • #14660
      Ivo Koubek
      Teilnehmer

        Hallo zusammen,

        sorry my Deutsche sprache grosse problem.

        My admin create operation TicketGet and I wrote Python script – everything is ok. Success!

        I use this code:

        import requests

        url = "https://our_server/otobo/nph-genericinterface.pl/Webservice/getotrs/TicketGet/2163024"

        payload = {
        "UserLogin": "username",
        "Password": "mypass",
        "AllArticles": "1",
        "Attachments": "1",
        }

        response = requests.get(url, params=payload, verify=False)

        perfecto, numero uno! Server return information…

         

        My admin created new operation with name TicketSearch and I use this code

        url = "https://our_server/otobo/nph-genericinterface.pl/Webservice/getotrs/TicketSearch"

        payload = {
        "UserLogin": "username",
        "Password": "mypass",
        "Data": { "TicketNumber": "2163024" }

        }

        response = requests.get(url, params=payload, verify=False)

        But i get error 500: HTTP::REST Error while determine Operation for request URI ‘/TicketSearch’.

        Please, bitte, can you help me?

        I am not able change setting, but my admin is good Boy. But he is very busy.

        Is it something special in setting, or I have error in my code?

        Thank you for your help

        Ivo

         

         

         

        • Dieses Thema wurde geändert vor 1 Jahr, 2 Monaten von Ivo Koubek.
        • Dieses Thema wurde geändert vor 1 Jahr, 2 Monaten von Ivo Koubek.
        • Dieses Thema wurde geändert vor 1 Jahr, 2 Monaten von Ivo Koubek.
      • #14665
        Ivo Koubek
        Teilnehmer

          solved … was wrong setting for routing
          everything is ok

      Ansicht von 1 Antwort-Thema
      • Das Thema „ Web Services – Ticket::TicketSearch – 500 error no return data – bitte hilfe“ ist für neue Antworten geschlossen.