Viewing 1 reply thread
  • Author
    Posts
    • #13389
      Marek Makowski
      Participant

      Guten Tag,

      ich habe Docker Installation genau nach der Anleitung vorgenommen.

      Es ist alles sauber durchgelaufen.

      Beide Befehle liefern:

      root@otobo:/opt/otobo-docker# docker-compose ps
      Name Command State Ports
      ————————————————————————————–
      otobo_daemon_1 /opt/otobo_install/entrypo … Up (unhealthy)
      otobo_db_1 docker-entrypoint.sh –max … Up (healthy) 3306/tcp
      otobo_elastic_1 /bin/tini — /usr/local/bi … Up (healthy) 9200/tcp, 9300/tcp
      otobo_nginx_1 /docker-entrypoint.sh ngin … Restarting
      otobo_redis_1 docker-entrypoint.sh redis … Up (healthy) 6379/tcp
      otobo_web_1 /opt/otobo_install/entrypo … Up (healthy)
      root@otobo:/opt/otobo-docker# docker volume ls
      DRIVER VOLUME NAME
      local otobo_elasticsearch_data
      local otobo_mariadb_data
      local otobo_nginx_ssl
      local otobo_opt_otobo
      local otobo_redis_data
      root@otobo:/opt/otobo-docker#

      Aber die Seite http://yourIPorFQDN/otobo/installer.pl kann ich nicht aufrufen.

      Vielen Dank für die Unterstützung

       

      Marek

    • #13397
      bes
      Participant

      Hallo Marek,

      in der Ausgabe von  docker ps  ist mir folgende Zeile aufgefallen:

      otobo_nginx_1 /docker-entrypoint.sh ngin … Restarting

      D.h. der Nginx-Proxy, der für die Unterstützung von HTTPS gebrauch wird, hat ein Problem. Ich kann mir vorstellen dass im Schritt 4 der Installationsanleitung, https://doc.otobo.org/manual/installation/10.0/de/content/installation-docker.html#set-up-a-volume-with-ssl-configuration-for-the-nginx-webproxy-optional, etwas nicht passt. Hinweise auf das Problem kann eventuell die Ausgabe von docker logs otobo_nginx_1 liefern.

      In der Doku steht auch der Link http://yourIPorFQDN/otobo/installer.pl . Das yourIPorFQDN ist natürlich nur ein Platzhalter für die tatsächliche URL. Wenn Sie einen Browser auf dem Docker-Host öffnen können, dann wäre die tatsächliche URL https://localhost/otobo/installer.pl. Wichtig ist dass das richtige Protokoll verwendet wird. In Ihrem Fall also https://.

      Siehe auch https://github.com/RotherOSS/doc-otobo-installation/issues/109.

      Viele Grüße,

      Bernahrd

       

       

       

       

       

       

       

       

Viewing 1 reply thread
  • You must be logged in to reply to this topic.