Ansicht von 4 Antwort-Themen
  • Autor
    Beiträge
    • #14551
      Abhishek Abhishek
      Teilnehmer

        Dear All,

        I have setup Otobo Docker Installation Version:10.1.1 with the help of:

        https://computingforgeeks.com/how-to-install-otrs-ticketing-system-on-ubuntu/

        where I am unable to send emails via Postfix GMAIL SMTP Relay though Otobo SMTPS though I can send emails through Ubuntu CLI. Fetch mail and Fetch MailSSL are disabled. I can receive the emails on Postmaster account and users are able to raise ticket by themselves as well. Users are not getting forgot password emails and the password email during signup. Below-mentioned is the error log which I can see in communication logs.

        Communication Log Details (5)

        Kernel::System::Email
        Building message for delivery.

        Kernel::System::Email
        Queuing message for delivery.

        Kernel::System::MailQueue
        Serializing and saving message (ArticleID: , Sender: myuser@gmail.com, Recipient: root@localhost, MessageID: )

        Kernel::System::MailQueue
        Successfully stored message for sending.

        Kernel::System::Email
        Successfully queued message for delivery (To: ‘root@localhost’, From: ‘myuser@gmail.com’, Subject: ‘OTOBO Scheduler Daemon Cron: MailQueueSend’).

        The problem is with the SMTP process only.

        AdminEmail: info@mycompany.org
        CheckEmailAddresses: Enabled
        CheckEmailInvalidAddress: @(example)\.(..|…)$
        CheckEmailValidAddress: ^(root@localhost|admin@localhost|otobo@localhost)$
        CheckMXRecord: Enabled
        CheckMXRecord::Nameserver: 8.8.8.8
        Fetchmail::Bin: Disabled
        NotificationSenderEmail: myuser@gmail.com
        NotificationSenderName: Support
        Sendmail::DefaultHeaders: Enabled
        SendmailBcc: Disabled
        SendmailEncodingForce: base64
        SendmailEnvelopeFrom: Disabled
        SendmailModule: Kernel::System::Email::SMTPS
        SendmailModule::AuthPassword: Gmail APP Password
        SendmailModule::AuthUser: myuser@gmail.com
        SendmailModule::CMD: /usr/sbin/sendmail -i -f
        SendmailModule::Host: smtp.gmail.com
        SendmailModule::Port: 465
        SendmailNotificationEnvelopeFrom: Disabled
        SendmailNotificationEnvelopeFrom::FallbackToEmailFrom: Disabled

        Please suggest

        Regards,
        Abhishek

      • #14552
        Abhishek Abhishek
        Teilnehmer

          This is to update that I can telnet smtp.gmail.com on ports 465 and 587 successfully from the base machine. There is no such network related issues with it.

        • #14575
          Abhishek Abhishek
          Teilnehmer

          • #14967
            Private Reply
            kps
            Teilnehmer
              This reply has been marked as private.
            • #14970
              kps
              Teilnehmer

                Hi Abhishek,

                in my test installation the requests went out to google. however, i get a “Bad Credentials” error back. Google does not support the login of “less secure apps” anymore and so there is no chance to use google at the moment.

                https://support.google.com/accounts/answer/6010255?hl=en

                For this oauth2 would have to be implemented for sending emails. For this you could write once to hallo@otobo.de and ask for an effort estimate.

                Otherwise you have to try to create a relay server to which OTOBO sends the mails and then they are forwarded to google.

                i hope i could help you a little bit, best regards,

                ~ kps

            Ansicht von 4 Antwort-Themen
            • Du musst angemeldet sein, um auf dieses Thema antworten zu können.